summaryrefslogtreecommitdiffstats
path: root/target/linux/rdc-2.6/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/rdc-2.6/Makefile')
-rw-r--r--target/linux/rdc-2.6/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/rdc-2.6/Makefile b/target/linux/rdc-2.6/Makefile
index 8452618ef9..1b5f34b30b 100644
--- a/target/linux/rdc-2.6/Makefile
+++ b/target/linux/rdc-2.6/Makefile
@@ -23,7 +23,7 @@ include $(INCLUDE_DIR)/kernel-build.mk
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
define Kernel/SetInitramfs
echo "r6040 parent=wlan0" > $(TARGET_DIR)/etc/modules.d/99-r6040
- $(RM) -f $(TARGET_DIR)/sbin/init
+ $(RM) $(TARGET_DIR)/sbin/init
ln -s /etc/preinit $(TARGET_DIR)/sbin/init
sed -i 's,exec /sbin/init,exec /bin/busybox init,g' $(TARGET_DIR)/etc/preinit
sed -i 's,/sbin/init,/bin/busybox init,g' $(TARGET_DIR)/init