summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.8/0080-MIPS-add-ohci-ehci-support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/patches-3.8/0080-MIPS-add-ohci-ehci-support.patch')
-rw-r--r--target/linux/ramips/patches-3.8/0080-MIPS-add-ohci-ehci-support.patch227
1 files changed, 227 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-3.8/0080-MIPS-add-ohci-ehci-support.patch b/target/linux/ramips/patches-3.8/0080-MIPS-add-ohci-ehci-support.patch
new file mode 100644
index 0000000000..0726ac8df6
--- /dev/null
+++ b/target/linux/ramips/patches-3.8/0080-MIPS-add-ohci-ehci-support.patch
@@ -0,0 +1,227 @@
+From ec6f3aa022ef6e61f6ca80c6e30610d879654466 Mon Sep 17 00:00:00 2001
+From: John Crispin <blogic@openwrt.org>
+Date: Thu, 20 Jun 2013 23:33:05 +0200
+Subject: [PATCH] MIPS: add ohci/ehci support
+
+Signed-off-by: John Crsipin <blogic@openwrt.org>
+---
+ arch/mips/ralink/Kconfig | 2 ++
+ drivers/usb/Makefile | 3 ++-
+ drivers/usb/host/ehci-platform.c | 43 ++++++++++++++++++++++++++++++++------
+ drivers/usb/host/ohci-platform.c | 37 +++++++++++++++++++++++++++-----
+ 4 files changed, 73 insertions(+), 12 deletions(-)
+
+diff --git a/arch/mips/ralink/Kconfig b/arch/mips/ralink/Kconfig
+index c8d5b6c..7cd1188 100644
+--- a/arch/mips/ralink/Kconfig
++++ b/arch/mips/ralink/Kconfig
+@@ -27,6 +27,8 @@ choice
+ bool "MT7620"
+ select CLKEVT_RT3352
+ select HW_HAS_PCI
++ select USB_ARCH_HAS_OHCI
++ select USB_ARCH_HAS_EHCI
+
+ endchoice
+
+diff --git a/drivers/usb/Makefile b/drivers/usb/Makefile
+index f5ed3d7..41a4741 100644
+--- a/drivers/usb/Makefile
++++ b/drivers/usb/Makefile
+@@ -12,6 +12,8 @@ obj-$(CONFIG_USB_DWC3) += dwc3/
+
+ obj-$(CONFIG_USB_MON) += mon/
+
++obj-$(CONFIG_USB_COMMON) += phy/
++
+ obj-$(CONFIG_PCI) += host/
+ obj-$(CONFIG_USB_EHCI_HCD) += host/
+ obj-$(CONFIG_USB_ISP116X_HCD) += host/
+@@ -46,7 +48,6 @@ obj-$(CONFIG_USB_MICROTEK) += image/
+ obj-$(CONFIG_USB_SERIAL) += serial/
+
+ obj-$(CONFIG_USB) += misc/
+-obj-$(CONFIG_USB_COMMON) += phy/
+ obj-$(CONFIG_EARLY_PRINTK_DBGP) += early/
+
+ obj-$(CONFIG_USB_ATM) += atm/
+diff --git a/drivers/usb/host/ehci-platform.c b/drivers/usb/host/ehci-platform.c
+index 58fa0c9..0050df7 100644
+--- a/drivers/usb/host/ehci-platform.c
++++ b/drivers/usb/host/ehci-platform.c
+@@ -23,6 +23,10 @@
+ #include <linux/io.h>
+ #include <linux/module.h>
+ #include <linux/platform_device.h>
++#include <linux/dma-mapping.h>
++#include <linux/of.h>
++#include <linux/usb/otg.h>
++#include <linux/usb/phy.h>
+ #include <linux/usb.h>
+ #include <linux/usb/hcd.h>
+ #include <linux/usb/ehci_pdriver.h>
+@@ -61,22 +65,40 @@ static const struct ehci_driver_overrides platform_overrides __initdata = {
+ .reset = ehci_platform_reset,
+ };
+
++static struct usb_ehci_pdata ehci_platform_defaults;
++
+ static int ehci_platform_probe(struct platform_device *dev)
+ {
+ struct usb_hcd *hcd;
+ struct resource *res_mem;
+- struct usb_ehci_pdata *pdata = dev->dev.platform_data;
++ struct usb_ehci_pdata *pdata;
+ int irq;
+ int err = -ENOMEM;
+
+- if (!pdata) {
+- WARN_ON(1);
+- return -ENODEV;
+- }
+-
+ if (usb_disabled())
+ return -ENODEV;
+
++ /*
++ * use reasonable defaults so platforms don't have to provide these.
++ * with DT probing on ARM, none of these are set.
++ */
++ if (!dev->dev.platform_data)
++ dev->dev.platform_data = &ehci_platform_defaults;
++ if (!dev->dev.dma_mask)
++ dev->dev.dma_mask = &dev->dev.coherent_dma_mask;
++ if (!dev->dev.coherent_dma_mask)
++ dev->dev.coherent_dma_mask = DMA_BIT_MASK(32);
++
++ pdata = dev->dev.platform_data;
++
++#ifdef CONFIG_USB_COMMON
++ hcd->phy = devm_usb_get_phy(&dev->dev, USB_PHY_TYPE_USB2);
++ if (!IS_ERR_OR_NULL(hcd->phy)) {
++ otg_set_host(hcd->phy->otg,
++ &hcd->self);
++ usb_phy_init(hcd->phy);
++ }
++#endif
+ irq = platform_get_irq(dev, 0);
+ if (irq < 0) {
+ dev_err(&dev->dev, "no irq provided");
+@@ -138,6 +160,9 @@ static int ehci_platform_remove(struct platform_device *dev)
+ if (pdata->power_off)
+ pdata->power_off(dev);
+
++ if (pdata == &ehci_platform_defaults)
++ dev->dev.platform_data = NULL;
++
+ return 0;
+ }
+
+@@ -182,6 +207,11 @@ static int ehci_platform_resume(struct device *dev)
+ #define ehci_platform_resume NULL
+ #endif /* CONFIG_PM */
+
++static const struct of_device_id ralink_ehci_ids[] = {
++ { .compatible = "ralink,rt3xxx-ehci", },
++ {}
++};
++
+ static const struct platform_device_id ehci_platform_table[] = {
+ { "ehci-platform", 0 },
+ { }
+@@ -202,6 +232,7 @@ static struct platform_driver ehci_platform_driver = {
+ .owner = THIS_MODULE,
+ .name = "ehci-platform",
+ .pm = &ehci_platform_pm_ops,
++ .of_match_table = of_match_ptr(ralink_ehci_ids),
+ }
+ };
+
+diff --git a/drivers/usb/host/ohci-platform.c b/drivers/usb/host/ohci-platform.c
+index 084503b..3a60f96 100644
+--- a/drivers/usb/host/ohci-platform.c
++++ b/drivers/usb/host/ohci-platform.c
+@@ -15,6 +15,10 @@
+ */
+ #include <linux/platform_device.h>
+ #include <linux/usb/ohci_pdriver.h>
++#include <linux/dma-mapping.h>
++#include <linux/of.h>
++
++static struct usb_ohci_pdata ohci_platform_defaults;
+
+ static int ohci_platform_reset(struct usb_hcd *hcd)
+ {
+@@ -87,14 +91,22 @@ static int ohci_platform_probe(struct platform_device *dev)
+ {
+ struct usb_hcd *hcd;
+ struct resource *res_mem;
+- struct usb_ohci_pdata *pdata = dev->dev.platform_data;
++ struct usb_ohci_pdata *pdata;
+ int irq;
+ int err = -ENOMEM;
+
+- if (!pdata) {
+- WARN_ON(1);
+- return -ENODEV;
+- }
++ /*
++ * use reasonable defaults so platforms don't have to provide these.
++ * with DT probing on ARM, none of these are set.
++ */
++ if (!dev->dev.platform_data)
++ dev->dev.platform_data = &ohci_platform_defaults;
++ if (!dev->dev.dma_mask)
++ dev->dev.dma_mask = &dev->dev.coherent_dma_mask;
++ if (!dev->dev.coherent_dma_mask)
++ dev->dev.coherent_dma_mask = DMA_BIT_MASK(32);
++
++ pdata = dev->dev.platform_data;
+
+ if (usb_disabled())
+ return -ENODEV;
+@@ -124,6 +136,12 @@ static int ohci_platform_probe(struct platform_device *dev)
+ goto err_power;
+ }
+
++#ifdef CONFIG_USB_COMMON
++ hcd->phy = devm_usb_get_phy(&dev->dev, USB_PHY_TYPE_USB2);
++ if (!IS_ERR_OR_NULL(hcd->phy))
++ usb_phy_init(hcd->phy);
++#endif
++
+ hcd->rsrc_start = res_mem->start;
+ hcd->rsrc_len = resource_size(res_mem);
+
+@@ -161,6 +179,9 @@ static int ohci_platform_remove(struct platform_device *dev)
+ if (pdata->power_off)
+ pdata->power_off(dev);
+
++ if (pdata == &ohci_platform_defaults)
++ dev->dev.platform_data = NULL;
++
+ return 0;
+ }
+
+@@ -200,6 +221,11 @@ static int ohci_platform_resume(struct device *dev)
+ #define ohci_platform_resume NULL
+ #endif /* CONFIG_PM */
+
++static const struct of_device_id ralink_ohci_ids[] = {
++ { .compatible = "ralink,rt3xxx-ohci", },
++ {}
++};
++
+ static const struct platform_device_id ohci_platform_table[] = {
+ { "ohci-platform", 0 },
+ { }
+@@ -220,5 +246,6 @@ static struct platform_driver ohci_platform_driver = {
+ .owner = THIS_MODULE,
+ .name = "ohci-platform",
+ .pm = &ohci_platform_pm_ops,
++ .of_match_table = of_match_ptr(ralink_ohci_ids),
+ }
+ };
+--
+1.7.10.4
+