summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7621/profiles/firefly.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/mt7621/profiles/firefly.mk')
-rw-r--r--target/linux/ramips/mt7621/profiles/firefly.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7621/profiles/firefly.mk b/target/linux/ramips/mt7621/profiles/firefly.mk
new file mode 100644
index 0000000000..c8292b0d00
--- /dev/null
+++ b/target/linux/ramips/mt7621/profiles/firefly.mk
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Firefly
+ NAME:=Firefly Device
+ PACKAGES:=\
+ kmod-usb-core kmod-usb3 kmod-usb-hid kmod-usb-storage mount-utils usbutils \
+ kmod-sdhci-mt7620 \
+ kmod-fs-ext3 kmod-fs-vfat kmod-fs-ntfs \
+ kmod-nls-cp437 kmod-nls-iso8859-1 kmod-nls-utf8 \
+ kmod-ledtrig-usbdev \
+ kmod-ata-core \
+ luci \
+ kmod-mt76
+endef
+
+define Profile/Firefly/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Firefly))