summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 5a2b98cac6..9521f2cfd0 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -954,7 +954,7 @@ endif
#
ifeq ($(SUBTARGET),mt7621)
- TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt pbr-m1 re6500 sap-g3200u3 zbt-wg2626
+ TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt pbr-m1 re6500 sap-g3200u3 zbt-wg2626 wf-2881
endif
define Device/mt7621
@@ -1009,6 +1009,15 @@ define Device/zbt-wg2626
IMAGE_SIZE := $(ralink_default_fw_size_16M)
endef
+define Device/wf-2881
+ DTS := WF-2881
+ BLOCKSIZE := 128KiB
+ PAGESIZE := 2048
+ KERNEL_SIZE := 2097152
+ FILESYSTEMS := squashfs
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | check-size $$$$(IMAGE_SIZE)
+endef
+
#
# MT7628 Profiles
#