summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index eb50cddeaf..f5e8e58ef9 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -1115,9 +1115,10 @@ define Device/wf-2881
DTS := WF-2881
BLOCKSIZE := 128KiB
PAGESIZE := 2048
- KERNEL_SIZE := 2097152
FILESYSTEMS := squashfs
- IMAGE/sysupgrade.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | check-size $$$$(IMAGE_SIZE)
+ IMAGE_SIZE := 132382720
+ KERNEL := $(KERNEL_DTB) | pad-offset 131072 64 | uImage lzma
+ IMAGE/sysupgrade.bin := append-kernel | append-ubi | check-size $$$$(IMAGE_SIZE)
endef
define Device/ubnt-erx