summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/files/arch/mips/ralink/common
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/files/arch/mips/ralink/common')
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/common/Makefile2
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/common/setup.c24
2 files changed, 25 insertions, 1 deletions
diff --git a/target/linux/ramips/files/arch/mips/ralink/common/Makefile b/target/linux/ramips/files/arch/mips/ralink/common/Makefile
index 24f67ea6c3..96f348a5a1 100644
--- a/target/linux/ramips/files/arch/mips/ralink/common/Makefile
+++ b/target/linux/ramips/files/arch/mips/ralink/common/Makefile
@@ -7,6 +7,6 @@
# under the terms of the GNU General Public License version 2 as published
# by the Free Software Foundation.
-obj-y := intc.o gpio.o
+obj-y := setup.o intc.o gpio.o
obj-$(CONFIG_RALINK_DEV_GPIO_LEDS) += dev-gpio-leds.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/common/setup.c b/target/linux/ramips/files/arch/mips/ralink/common/setup.c
new file mode 100644
index 0000000000..6440ccb01a
--- /dev/null
+++ b/target/linux/ramips/files/arch/mips/ralink/common/setup.c
@@ -0,0 +1,24 @@
+/*
+ * Ralink SoC common setup
+ *
+ * Copyright (C) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
+ * Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/kernel.h>
+#include <linux/init.h>
+#include <linux/io.h>
+
+#include <asm/addrspace.h>
+#include <asm/mach-ralink/common.h>
+
+void __init plat_mem_setup(void)
+{
+ set_io_port_base(KSEG1);
+
+ ramips_soc_setup();
+}