summaryrefslogtreecommitdiffstats
path: root/target/linux/ppc40x
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ppc40x')
-rw-r--r--target/linux/ppc40x/image/Makefile10
-rw-r--r--target/linux/ppc40x/patches-3.8/004-magicbox.patch4
-rw-r--r--target/linux/ppc40x/patches-3.8/005-openrb.patch4
3 files changed, 9 insertions, 9 deletions
diff --git a/target/linux/ppc40x/image/Makefile b/target/linux/ppc40x/image/Makefile
index 415539e9cc..dae5de5dff 100644
--- a/target/linux/ppc40x/image/Makefile
+++ b/target/linux/ppc40x/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -37,11 +37,11 @@ endef
define Image/Build/jffs2-64k
( \
- dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicbox bs=1280k conv=sync; \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicbox bs=1408k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/$(IMG_PREFIX)-magicbox-jffs2.img
( \
- dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb bs=1280k conv=sync; \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb bs=1408k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/$(IMG_PREFIX)-openrb-jffs2.img
endef
@@ -54,11 +54,11 @@ define Image/Build/squashfs
dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
) > $(BIN_DIR)/$(IMG_PREFIX)-kilauea-$(1).img
( \
- dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicbox bs=1280k conv=sync; \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicbox bs=1408k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/$(IMG_PREFIX)-magicbox-$(1).img
( \
- dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb bs=1280k conv=sync; \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb bs=1408k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/$(IMG_PREFIX)-openrb-$(1).img
endef
diff --git a/target/linux/ppc40x/patches-3.8/004-magicbox.patch b/target/linux/ppc40x/patches-3.8/004-magicbox.patch
index 75ff889798..717b1f7760 100644
--- a/target/linux/ppc40x/patches-3.8/004-magicbox.patch
+++ b/target/linux/ppc40x/patches-3.8/004-magicbox.patch
@@ -326,11 +326,11 @@
+ #size-cells = <1>;
+ partition0@0 {
+ label = "linux";
-+ reg = <0x0 0x140000>;
++ reg = <0x0 0x160000>;
+ };
+ partition1@120000 {
+ label = "rootfs";
-+ reg = <0x140000 0x280000>;
++ reg = <0x160000 0x260000>;
+ };
+ partition2@3c0000 {
+ label = "u-boot";
diff --git a/target/linux/ppc40x/patches-3.8/005-openrb.patch b/target/linux/ppc40x/patches-3.8/005-openrb.patch
index 3c1f0ae503..116ee09ca3 100644
--- a/target/linux/ppc40x/patches-3.8/005-openrb.patch
+++ b/target/linux/ppc40x/patches-3.8/005-openrb.patch
@@ -328,11 +328,11 @@
+ #size-cells = <1>;
+ partition0@0 {
+ label = "linux";
-+ reg = <0x0 0x140000>;
++ reg = <0x0 0x160000>;
+ };
+ partition1@120000 {
+ label = "rootfs";
-+ reg = <0x140000 0x680000>;
++ reg = <0x160000 0x660000>;
+ };
+ partition2@7c0000 {
+ label = "u-boot";