summaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/profiles/shuttle.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/oxnas/profiles/shuttle.mk')
-rw-r--r--target/linux/oxnas/profiles/shuttle.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/oxnas/profiles/shuttle.mk b/target/linux/oxnas/profiles/shuttle.mk
new file mode 100644
index 0000000000..a83935f9c5
--- /dev/null
+++ b/target/linux/oxnas/profiles/shuttle.mk
@@ -0,0 +1,18 @@
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/KD20
+ NAME:=Shuttle KD20
+ PACKAGES:= \
+ kmod-usb3 kmod-usb-storage kmod-i2c-gpio kmod-rtc-pcf8563 \
+ kmod-gpio-beeper kmod-hwmon-core kmod-hwmon-gpiofan
+endef
+
+define Profile/KD20/Description
+ Profile with built-in ox820 KD20 device-tree
+endef
+
+$(eval $(call Profile,KD20))