summaryrefslogtreecommitdiffstats
path: root/target/linux/openmoko/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/openmoko/image/Makefile')
-rw-r--r--target/linux/openmoko/image/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/openmoko/image/Makefile b/target/linux/openmoko/image/Makefile
new file mode 100644
index 0000000000..20f17590f3
--- /dev/null
+++ b/target/linux/openmoko/image/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Build/Clean
+endef
+
+define Build/Compile
+endef
+
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
+endef
+
+define Image/BuildKernel
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+endef
+
+define Image/Build
+endef
+
+$(eval $(call BuildImage))