summaryrefslogtreecommitdiffstats
path: root/target/linux/omap24xx/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/omap24xx/image/Makefile')
-rw-r--r--target/linux/omap24xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/omap24xx/image/Makefile b/target/linux/omap24xx/image/Makefile
index 7a3429fa6c..316cce0f9f 100644
--- a/target/linux/omap24xx/image/Makefile
+++ b/target/linux/omap24xx/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/image.mk
NAND_BLOCKSIZE=2048-128k
define Image/BuildKernel
- $(CP) $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
+ cat $(KDIR)/zImage $(DTS_DIR)/omap2420-n810.dtb > $(BIN_DIR)/$(IMG_PREFIX)-zImage
chmod 0644 $(BIN_DIR)/$(IMG_PREFIX)-zImage
endef