summaryrefslogtreecommitdiffstats
path: root/target/linux/omap/patches-3.12/405-ASoC-davinci-Add-support-for-AM33xx-SoC-Audio.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/omap/patches-3.12/405-ASoC-davinci-Add-support-for-AM33xx-SoC-Audio.patch')
-rw-r--r--target/linux/omap/patches-3.12/405-ASoC-davinci-Add-support-for-AM33xx-SoC-Audio.patch60
1 files changed, 0 insertions, 60 deletions
diff --git a/target/linux/omap/patches-3.12/405-ASoC-davinci-Add-support-for-AM33xx-SoC-Audio.patch b/target/linux/omap/patches-3.12/405-ASoC-davinci-Add-support-for-AM33xx-SoC-Audio.patch
deleted file mode 100644
index ddc2b82f22..0000000000
--- a/target/linux/omap/patches-3.12/405-ASoC-davinci-Add-support-for-AM33xx-SoC-Audio.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From 8f3e1fa024017a6b3d7fd8c2a75ee6ff5e4127f8 Mon Sep 17 00:00:00 2001
-From: "Hebbar, Gururaja" <gururaja.hebbar@ti.com>
-Date: Wed, 1 Aug 2012 12:04:22 +0530
-Subject: [PATCH 216/752] ASoC: davinci: Add support for AM33xx SoC Audio
-
-AM33xx uses same McASP IP as the Davinci Platform. This patch updates
-Kconfig and makefile to enable build for McASP, PCM & Codec drivers.
-
-Signed-off-by: Hebbar, Gururaja <gururaja.hebbar@ti.com>
-Signed-off-by: Darren Etheridge <detheridge@ti.com>
-Signed-off-by: Jyri Sarha <jsarha@ti.com>
----
- sound/soc/davinci/Kconfig | 18 +++++++++++++++---
- sound/soc/davinci/Makefile | 1 +
- 2 files changed, 16 insertions(+), 3 deletions(-)
-
---- a/sound/soc/davinci/Kconfig
-+++ b/sound/soc/davinci/Kconfig
-@@ -1,9 +1,10 @@
- config SND_DAVINCI_SOC
-- tristate "SoC Audio for the TI DAVINCI chip"
-- depends on ARCH_DAVINCI
-+ tristate "SoC Audio for the TI DAVINCI or AM33XX chip"
-+ depends on ARCH_DAVINCI || SOC_AM33XX
- help
-+ Platform driver for daVinci or AM33xx
- Say Y or M if you want to add support for codecs attached to
-- the DAVINCI AC97 or I2S interface. You will also need
-+ the DAVINCI AC97, I2S, or McASP interface. You will also need
- to select the audio interfaces to support below.
-
- config SND_DAVINCI_SOC_I2S
-@@ -15,6 +16,17 @@ config SND_DAVINCI_SOC_MCASP
- config SND_DAVINCI_SOC_VCIF
- tristate
-
-+config SND_AM33XX_SOC_EVM
-+ tristate "SoC Audio for the AM33XX chip based boards"
-+ depends on SND_DAVINCI_SOC && SOC_AM33XX
-+ select SND_SOC_TLV320AIC3X
-+ select SND_DAVINCI_SOC_MCASP
-+ help
-+ Say Y or M if you want to add support for SoC audio on AM33XX
-+ boards using McASP and TLV320AIC3X codec. For example AM335X-EVM,
-+ AM335X-EVMSK, and BeagelBone with AudioCape boards have this
-+ setup.
-+
- config SND_DAVINCI_SOC_EVM
- tristate "SoC Audio support for DaVinci DM6446, DM355 or DM365 EVM"
- depends on SND_DAVINCI_SOC
---- a/sound/soc/davinci/Makefile
-+++ b/sound/soc/davinci/Makefile
-@@ -13,6 +13,7 @@ obj-$(CONFIG_SND_DAVINCI_SOC_VCIF) += sn
- snd-soc-evm-objs := davinci-evm.o
-
- obj-$(CONFIG_SND_DAVINCI_SOC_EVM) += snd-soc-evm.o
-+obj-$(CONFIG_SND_AM33XX_SOC_EVM) += snd-soc-evm.o
- obj-$(CONFIG_SND_DM6467_SOC_EVM) += snd-soc-evm.o
- obj-$(CONFIG_SND_DA830_SOC_EVM) += snd-soc-evm.o
- obj-$(CONFIG_SND_DA850_SOC_EVM) += snd-soc-evm.o