summaryrefslogtreecommitdiffstats
path: root/target/linux/olpc/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/olpc/image/Makefile')
-rw-r--r--target/linux/olpc/image/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/olpc/image/Makefile b/target/linux/olpc/image/Makefile
index 4945022ba7..eb1bedd0a0 100644
--- a/target/linux/olpc/image/Makefile
+++ b/target/linux/olpc/image/Makefile
@@ -15,19 +15,19 @@ ROOTDELAY=5
ifeq ($(CONFIG_OLPC_BOOTSCRIPT_IMAGES),y)
define Image/cmdline/squashfs
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs init=/etc/preinit rootdelay=$(ROOTDELAY)
+ block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs rootdelay=$(ROOTDELAY)
endef
define Image/cmdline/jffs2-64k
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit rootdelay=$(ROOTDELAY)
+ block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootdelay=$(ROOTDELAY)
endef
define Image/cmdline/jffs2-128k
- block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit rootdelay=$(ROOTDELAY)
+ block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootdelay=$(ROOTDELAY)
endef
define Image/cmdline/ext2
- root=$(ROOTPART) rootfstype=ext2 init=/etc/preinit
+ root=$(ROOTPART) rootfstype=ext2
endef
define Image/Build/bootscript