summaryrefslogtreecommitdiffstats
path: root/target/linux/mx2/patches-2.6.34/030-lzma.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mx2/patches-2.6.34/030-lzma.patch')
-rw-r--r--target/linux/mx2/patches-2.6.34/030-lzma.patch22
1 files changed, 5 insertions, 17 deletions
diff --git a/target/linux/mx2/patches-2.6.34/030-lzma.patch b/target/linux/mx2/patches-2.6.34/030-lzma.patch
index 9ccabf6a79..90a1e87603 100644
--- a/target/linux/mx2/patches-2.6.34/030-lzma.patch
+++ b/target/linux/mx2/patches-2.6.34/030-lzma.patch
@@ -17,8 +17,6 @@ v2: Updated to apply on top of 2.6.34-rc1
4 files changed, 12 insertions(+), 0 deletions(-)
create mode 100644 arch/arm/boot/compressed/piggy.lzma.S
-diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
-index 3b18128..3ebc7c3 100644
--- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig
@@ -21,6 +21,7 @@ config ARM
@@ -29,26 +27,22 @@ index 3b18128..3ebc7c3 100644
select HAVE_PERF_EVENTS
select PERF_USE_VMALLOC
help
-diff --git a/arch/arm/boot/compressed/Makefile b/arch/arm/boot/compressed/Makefile
-index 97c89e7..53faa90 100644
--- a/arch/arm/boot/compressed/Makefile
+++ b/arch/arm/boot/compressed/Makefile
-@@ -65,6 +65,7 @@ SEDFLAGS = s/TEXT_START/$(ZTEXTADDR)/;s/BSS_START/$(ZBSSADDR)/
-
+@@ -65,6 +65,7 @@ SEDFLAGS = s/TEXT_START/$(ZTEXTADDR)/;s/
+
suffix_$(CONFIG_KERNEL_GZIP) = gzip
suffix_$(CONFIG_KERNEL_LZO) = lzo
+suffix_$(CONFIG_KERNEL_LZMA) = lzma
-
+
targets := vmlinux vmlinux.lds \
piggy.$(suffix_y) piggy.$(suffix_y).o \
-diff --git a/arch/arm/boot/compressed/decompress.c b/arch/arm/boot/compressed/decompress.c
-index 0da382f..d554df6 100644
--- a/arch/arm/boot/compressed/decompress.c
+++ b/arch/arm/boot/compressed/decompress.c
-@@ -39,6 +39,10 @@ extern void error(char *);
+@@ -40,6 +40,10 @@ extern void error(char *);
#include "../../../../lib/decompress_unlzo.c"
#endif
-
+
+#ifdef CONFIG_KERNEL_LZMA
+#include "../../../../lib/decompress_unlzma.c"
+#endif
@@ -56,9 +50,6 @@ index 0da382f..d554df6 100644
void do_decompress(u8 *input, int len, u8 *output, void (*error)(char *x))
{
decompress(input, len, NULL, NULL, output, NULL, error);
-diff --git a/arch/arm/boot/compressed/piggy.lzma.S b/arch/arm/boot/compressed/piggy.lzma.S
-new file mode 100644
-index 0000000..d7e69cf
--- /dev/null
+++ b/arch/arm/boot/compressed/piggy.lzma.S
@@ -0,0 +1,6 @@
@@ -68,6 +59,3 @@ index 0000000..d7e69cf
+ .incbin "arch/arm/boot/compressed/piggy.lzma"
+ .globl input_data_end
+input_data_end:
---
-1.7.0
-