summaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mcs814x')
-rw-r--r--target/linux/mcs814x/image/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/target/linux/mcs814x/image/Makefile b/target/linux/mcs814x/image/Makefile
index 1c814fa4fd..7f8722d6bd 100644
--- a/target/linux/mcs814x/image/Makefile
+++ b/target/linux/mcs814x/image/Makefile
@@ -9,6 +9,12 @@ include $(INCLUDE_DIR)/image.mk
TARGET_DTBS := rbt-832 dlan-usb-extender
+ifeq ($(KERNEL_PATCHVER),3.3)
+DTBS_DIR:=
+else
+DTBS_DIR:=dts/
+endif
+
LOADADDR:=0x00008000
JFFS2_BLOCKSIZE = 128k
@@ -22,7 +28,7 @@ endef
define Image/Build/DTB
cp $(KDIR)/zImage$(2) $(KDIR)/zImage-$(1);
- cat $(LINUX_DIR)/arch/$(ARCH)/boot/$(1).dtb >> $(KDIR)/zImage$(2)-$(1);
+ cat $(LINUX_DIR)/arch/$(ARCH)/boot/$(DTBS_DIR)$(1).dtb >> $(KDIR)/zImage$(2)-$(1);
$(call Image/Build/MkuImage,$(KDIR)/zImage$(2)-$(1),$(KDIR)/uImage$(2)-$(1))
cp $(KDIR)/uImage$(2)-$(1) $(UIMAGE)$(2)-$(1);
endef