summaryrefslogtreecommitdiffstats
path: root/target/linux/malta/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/malta/Makefile')
-rw-r--r--target/linux/malta/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/malta/Makefile b/target/linux/malta/Makefile
new file mode 100644
index 0000000000..69fae6aa5b
--- /dev/null
+++ b/target/linux/malta/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mipsel
+BOARD:=malta
+BOARDNAME:=MIPS Malta CoreLV board (qemu)
+FEATURES:=ramdisk
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
+
+LINUX_VERSION:=2.6.32.8
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build firmware images for MTI Malta CoreLV boards.
+endef
+
+$(eval $(call BuildTarget))