summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/ase
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/lantiq/ase')
-rw-r--r--target/linux/lantiq/ase/config-2.6.3215
-rw-r--r--target/linux/lantiq/ase/config-default39
-rw-r--r--target/linux/lantiq/ase/profiles/000-generic.mk6
-rw-r--r--target/linux/lantiq/ase/profiles/001-lantiq.mk10
-rw-r--r--target/linux/lantiq/ase/target.mk10
5 files changed, 80 insertions, 0 deletions
diff --git a/target/linux/lantiq/ase/config-2.6.32 b/target/linux/lantiq/ase/config-2.6.32
new file mode 100644
index 0000000000..a3b8453fd4
--- /dev/null
+++ b/target/linux/lantiq/ase/config-2.6.32
@@ -0,0 +1,15 @@
+CONFIG_CRYPTO_ALGAPI=y
+CONFIG_CRYPTO_ALGAPI2=y
+# CONFIG_DM9000 is not set
+CONFIG_INPUT=y
+CONFIG_INPUT_EVDEV=y
+# CONFIG_INPUT_GPIO_BUTTONS is not set
+CONFIG_INPUT_POLLDEV=y
+# CONFIG_ISDN is not set
+CONFIG_LANTIQ_ETOP=y
+CONFIG_LANTIQ_MACH_EASY50601=y
+CONFIG_SOC_AMAZON_SE=y
+# CONFIG_SOC_FALCON is not set
+CONFIG_SOC_TYPE_XWAY=y
+# CONFIG_SOC_XWAY is not set
+# CONFIG_I2C_DESIGNWARE is not set
diff --git a/target/linux/lantiq/ase/config-default b/target/linux/lantiq/ase/config-default
new file mode 100644
index 0000000000..a1b6766890
--- /dev/null
+++ b/target/linux/lantiq/ase/config-default
@@ -0,0 +1,39 @@
+# CONFIG_ARCH_DMA_ADDR_T_64BIT is not set
+# CONFIG_ARCH_PHYS_ADDR_T_64BIT is not set
+# CONFIG_ATH79 is not set
+CONFIG_CRYPTO_ALGAPI=y
+CONFIG_CRYPTO_ALGAPI2=y
+CONFIG_GENERIC_ATOMIC64=y
+CONFIG_GENERIC_IRQ_SHOW=y
+CONFIG_HAVE_ARCH_JUMP_LABEL=y
+CONFIG_HAVE_C_RECORDMCOUNT=y
+CONFIG_HAVE_DMA_API_DEBUG=y
+CONFIG_HAVE_DMA_ATTRS=y
+CONFIG_HAVE_DYNAMIC_FTRACE=y
+CONFIG_HAVE_FTRACE_MCOUNT_RECORD=y
+CONFIG_HAVE_FUNCTION_GRAPH_TRACER=y
+CONFIG_HAVE_FUNCTION_TRACER=y
+CONFIG_HAVE_FUNCTION_TRACE_MCOUNT_TEST=y
+CONFIG_HAVE_GENERIC_HARDIRQS=y
+CONFIG_HAVE_IRQ_WORK=y
+CONFIG_HAVE_PERF_EVENTS=y
+CONFIG_INPUT=y
+CONFIG_INPUT_EVDEV=y
+# CONFIG_INPUT_GPIO_BUTTONS is not set
+CONFIG_INPUT_POLLDEV=y
+# CONFIG_ISDN is not set
+CONFIG_LANTIQ_ETOP=y
+CONFIG_LANTIQ_MACH_EASY50601=y
+CONFIG_MACH_NO_WESTBRIDGE=y
+# CONFIG_MINIX_FS_NATIVE_ENDIAN is not set
+# CONFIG_MTD_LATCH_ADDR is not set
+CONFIG_NEED_DMA_MAP_STATE=y
+CONFIG_NEED_PER_CPU_KM=y
+CONFIG_PERF_USE_VMALLOC=y
+# CONFIG_PREEMPT_RCU is not set
+# CONFIG_QUOTACTL is not set
+CONFIG_SOC_AMAZON_SE=y
+# CONFIG_SOC_FALCON is not set
+CONFIG_SOC_TYPE_XWAY=y
+# CONFIG_SOC_XWAY is not set
+CONFIG_XZ_DEC=y
diff --git a/target/linux/lantiq/ase/profiles/000-generic.mk b/target/linux/lantiq/ase/profiles/000-generic.mk
new file mode 100644
index 0000000000..787a74fba2
--- /dev/null
+++ b/target/linux/lantiq/ase/profiles/000-generic.mk
@@ -0,0 +1,6 @@
+define Profile/Generic
+ NAME:=Generic - all boards
+ PACKAGES:=kmod-leds-gpio button-hotplug
+endef
+
+$(eval $(call Profile,Generic))
diff --git a/target/linux/lantiq/ase/profiles/001-lantiq.mk b/target/linux/lantiq/ase/profiles/001-lantiq.mk
new file mode 100644
index 0000000000..dd763bda7e
--- /dev/null
+++ b/target/linux/lantiq/ase/profiles/001-lantiq.mk
@@ -0,0 +1,10 @@
+define Profile/EASY50601
+ NAME:=EASY50601
+ PACKAGES:= kmod-usb-core kmod-usb-dwc-otg kmod-leds-gpio
+endef
+
+define Profile/EASY50601/Description
+ Lantiq EASY50601 evalkit
+endef
+
+$(eval $(call Profile,EASY50601))
diff --git a/target/linux/lantiq/ase/target.mk b/target/linux/lantiq/ase/target.mk
new file mode 100644
index 0000000000..343edf98ef
--- /dev/null
+++ b/target/linux/lantiq/ase/target.mk
@@ -0,0 +1,10 @@
+ARCH:=mips
+SUBTARGET:=ase
+BOARDNAME:=Amazon-SE
+FEATURES:=squashfs jffs2 atm
+
+DEFAULT_PACKAGES+=kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl kmod-ltq-dsl ltq-dsl-app
+
+define Target/Description
+ Lantiq ASE
+endef