summaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/kirkwood')
-rw-r--r--target/linux/kirkwood/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 12d2a311ef..80bd01942e 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -59,7 +59,7 @@ define Device/linksys-audi
FILESYSTEMS := squashfs
PROFILES := Generic AUDI
IMAGES += factory.bin
- IMAGE/factory.bin := append-kernel $$$$(KERNEL_SIZE) | append-ubi
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
endef
define Device/linksys-viper
@@ -68,7 +68,7 @@ define Device/linksys-viper
FILESYSTEMS := squashfs
PROFILES := Generic VIPER
IMAGES += factory.bin
- IMAGE/factory.bin := append-kernel $$$$(KERNEL_SIZE) | append-ubi
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
endef
define Image/BuildKernel/Template