summaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/patches/139-ixp4xx_net_driver_mtd_load_fw.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ixp4xx/patches/139-ixp4xx_net_driver_mtd_load_fw.patch')
-rw-r--r--target/linux/ixp4xx/patches/139-ixp4xx_net_driver_mtd_load_fw.patch54
1 files changed, 27 insertions, 27 deletions
diff --git a/target/linux/ixp4xx/patches/139-ixp4xx_net_driver_mtd_load_fw.patch b/target/linux/ixp4xx/patches/139-ixp4xx_net_driver_mtd_load_fw.patch
index ef53155c03..9ed1b42fe7 100644
--- a/target/linux/ixp4xx/patches/139-ixp4xx_net_driver_mtd_load_fw.patch
+++ b/target/linux/ixp4xx/patches/139-ixp4xx_net_driver_mtd_load_fw.patch
@@ -7,11 +7,11 @@
include/linux/ixp_npe.h | 1
6 files changed, 239 insertions(+), 20 deletions(-)
-Index: linux-2.6.20-rc3/drivers/net/ixp4xx/Kconfig
+Index: linux-2.6.21.7/drivers/net/ixp4xx/Kconfig
===================================================================
---- linux-2.6.20-rc3.orig/drivers/net/ixp4xx/Kconfig
-+++ linux-2.6.20-rc3/drivers/net/ixp4xx/Kconfig
-@@ -11,6 +11,7 @@
+--- linux-2.6.21.7.orig/drivers/net/ixp4xx/Kconfig
++++ linux-2.6.21.7/drivers/net/ixp4xx/Kconfig
+@@ -11,6 +11,7 @@ config IXP4XX_NPE
tristate "IXP4xx NPE support"
depends on ARCH_IXP4XX
depends on NET_ETHERNET
@@ -19,7 +19,7 @@ Index: linux-2.6.20-rc3/drivers/net/ixp4xx/Kconfig
help
The IXP4XX NPE driver supports the 3 CPU co-processors called
"Network Processing Engines" (NPE). It adds support fo downloading
-@@ -18,7 +19,7 @@
+@@ -18,7 +19,7 @@ config IXP4XX_NPE
More about this at: Documentation/networking/ixp4xx/README.
You can either use this OR the Intel Access Library (IAL)
@@ -28,7 +28,7 @@ Index: linux-2.6.20-rc3/drivers/net/ixp4xx/Kconfig
bool "Use Firmware hotplug for Microcode download"
depends on IXP4XX_NPE
select HOTPLUG
-@@ -28,6 +29,13 @@
+@@ -28,6 +29,13 @@ config IXP4XX_FW_LOAD
/usr/lib/hotplug/firmware/NPE-[ABC]
see Documentation/firmware_class/hotplug-script
@@ -42,10 +42,10 @@ Index: linux-2.6.20-rc3/drivers/net/ixp4xx/Kconfig
config IXP4XX_MAC
tristate "IXP4xx MAC support"
depends on IXP4XX_NPE
-Index: linux-2.6.20-rc3/drivers/net/ixp4xx/Makefile
+Index: linux-2.6.21.7/drivers/net/ixp4xx/Makefile
===================================================================
---- linux-2.6.20-rc3.orig/drivers/net/ixp4xx/Makefile
-+++ linux-2.6.20-rc3/drivers/net/ixp4xx/Makefile
+--- linux-2.6.21.7.orig/drivers/net/ixp4xx/Makefile
++++ linux-2.6.21.7/drivers/net/ixp4xx/Makefile
@@ -1,5 +1,6 @@
obj-$(CONFIG_IXP4XX_QMGR) += ixp4xx_qmgr.o
obj-$(CONFIG_IXP4XX_NPE) += ixp4xx_npe.o
@@ -53,10 +53,10 @@ Index: linux-2.6.20-rc3/drivers/net/ixp4xx/Makefile
obj-$(CONFIG_IXP4XX_MAC) += ixp4xx_mac.o
obj-$(CONFIG_IXP4XX_CRYPTO) += ixp4xx_crypto.o
-Index: linux-2.6.20-rc3/drivers/net/ixp4xx/npe_ucode.c
+Index: linux-2.6.21.7/drivers/net/ixp4xx/npe_ucode.c
===================================================================
--- /dev/null
-+++ linux-2.6.20-rc3/drivers/net/ixp4xx/npe_ucode.c
++++ linux-2.6.21.7/drivers/net/ixp4xx/npe_ucode.c
@@ -0,0 +1,185 @@
+/*
+ * Provide an NPE platform device for microcode handling
@@ -243,10 +243,10 @@ Index: linux-2.6.20-rc3/drivers/net/ixp4xx/npe_ucode.c
+
+MODULE_LICENSE("GPL");
+MODULE_AUTHOR("Alessandro Zummo <a.zummo@towertech.it>");
-Index: linux-2.6.20-rc3/drivers/net/ixp4xx/ucode_dl.c
+Index: linux-2.6.21.7/drivers/net/ixp4xx/ucode_dl.c
===================================================================
---- linux-2.6.20-rc3.orig/drivers/net/ixp4xx/ucode_dl.c
-+++ linux-2.6.20-rc3/drivers/net/ixp4xx/ucode_dl.c
+--- linux-2.6.21.7.orig/drivers/net/ixp4xx/ucode_dl.c
++++ linux-2.6.21.7/drivers/net/ixp4xx/ucode_dl.c
@@ -16,6 +16,7 @@
#include <linux/firmware.h>
#include <linux/dma-mapping.h>
@@ -268,7 +268,7 @@ Index: linux-2.6.20-rc3/drivers/net/ixp4xx/ucode_dl.c
#define EOF_BLOCK 0xf
#define IMG_SIZE(image) (((image)->size * sizeof(u32)) + \
sizeof(struct dl_image))
-@@ -38,21 +45,6 @@
+@@ -38,21 +45,6 @@ enum blk_type {
data,
};
@@ -290,7 +290,7 @@ Index: linux-2.6.20-rc3/drivers/net/ixp4xx/ucode_dl.c
struct dl_codeblock {
u32 npe_addr;
u32 size;
-@@ -127,20 +119,33 @@
+@@ -127,20 +119,33 @@ download_block(struct npe_info *npe, str
return 0;
}
@@ -326,7 +326,7 @@ Index: linux-2.6.20-rc3/drivers/net/ixp4xx/ucode_dl.c
npe = dev_get_drvdata(dev);
if (npe->loaded && (npe->usage > 0)) {
printk(KERN_INFO "Cowardly refusing to reload an Image "
-@@ -267,8 +272,7 @@
+@@ -267,8 +272,7 @@ static ssize_t ucode_write(struct file *
static void npe_firmware_probe(struct device *dev)
{
@@ -336,16 +336,16 @@ Index: linux-2.6.20-rc3/drivers/net/ixp4xx/ucode_dl.c
const struct firmware *fw_entry;
struct npe_info *npe = dev_get_drvdata(dev);
struct dl_image *image;
-@@ -477,3 +481,4 @@
+@@ -477,3 +481,4 @@ MODULE_AUTHOR("Christian Hohnstaedt <cho
EXPORT_SYMBOL(get_npe_by_id);
EXPORT_SYMBOL(return_npe_dev);
+EXPORT_SYMBOL(store_npe_image);
-Index: linux-2.6.20-rc3/include/asm-arm/arch-ixp4xx/platform.h
+Index: linux-2.6.21.7/include/asm-arm/arch-ixp4xx/platform.h
===================================================================
---- linux-2.6.20-rc3.orig/include/asm-arm/arch-ixp4xx/platform.h
-+++ linux-2.6.20-rc3/include/asm-arm/arch-ixp4xx/platform.h
-@@ -86,6 +86,21 @@
+--- linux-2.6.21.7.orig/include/asm-arm/arch-ixp4xx/platform.h
++++ linux-2.6.21.7/include/asm-arm/arch-ixp4xx/platform.h
+@@ -86,6 +86,21 @@ struct ixp4xx_i2c_pins {
unsigned long scl_pin;
};
@@ -367,7 +367,7 @@ Index: linux-2.6.20-rc3/include/asm-arm/arch-ixp4xx/platform.h
struct npe_plat_data {
const char *name;
int data_size;
-@@ -105,6 +120,10 @@
+@@ -105,6 +120,10 @@ struct mac_plat_info {
};
@@ -378,11 +378,11 @@ Index: linux-2.6.20-rc3/include/asm-arm/arch-ixp4xx/platform.h
/*
* This structure provide a means for the board setup code
* to give information to th pata_ixp4xx driver. It is
-Index: linux-2.6.20-rc3/include/linux/ixp_npe.h
+Index: linux-2.6.21.7/include/linux/ixp_npe.h
===================================================================
---- linux-2.6.20-rc3.orig/include/linux/ixp_npe.h
-+++ linux-2.6.20-rc3/include/linux/ixp_npe.h
-@@ -99,6 +99,7 @@
+--- linux-2.6.21.7.orig/include/linux/ixp_npe.h
++++ linux-2.6.21.7/include/linux/ixp_npe.h
+@@ -99,6 +99,7 @@ extern void npe_reset(struct npe_info *n
extern struct device *get_npe_by_id(int id);
extern void return_npe_dev(struct device *dev);