summaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/patches/050-dsmg600_upstream_support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ixp4xx/patches/050-dsmg600_upstream_support.patch')
-rw-r--r--target/linux/ixp4xx/patches/050-dsmg600_upstream_support.patch48
1 files changed, 24 insertions, 24 deletions
diff --git a/target/linux/ixp4xx/patches/050-dsmg600_upstream_support.patch b/target/linux/ixp4xx/patches/050-dsmg600_upstream_support.patch
index b214ef2b5f..5f27aa7999 100644
--- a/target/linux/ixp4xx/patches/050-dsmg600_upstream_support.patch
+++ b/target/linux/ixp4xx/patches/050-dsmg600_upstream_support.patch
@@ -24,11 +24,11 @@ Signed-off-by: Michael Westerhof <mwester@dls.net>
include/asm-arm/arch-ixp4xx/irqs.h | 10 +
8 files changed, 458 insertions(+)
-Index: linux-2.6.21.1-armeb/arch/arm/mach-ixp4xx/Kconfig
+Index: linux-2.6.21.7/arch/arm/mach-ixp4xx/Kconfig
===================================================================
---- linux-2.6.21.1-armeb.orig/arch/arm/mach-ixp4xx/Kconfig
-+++ linux-2.6.21.1-armeb/arch/arm/mach-ixp4xx/Kconfig
-@@ -89,6 +89,15 @@
+--- linux-2.6.21.7.orig/arch/arm/mach-ixp4xx/Kconfig
++++ linux-2.6.21.7/arch/arm/mach-ixp4xx/Kconfig
+@@ -89,6 +89,15 @@ config MACH_NAS100D
NAS 100d device. For more information on this platform,
see http://www.nslu2-linux.org/wiki/NAS100d/HomePage
@@ -44,11 +44,11 @@ Index: linux-2.6.21.1-armeb/arch/arm/mach-ixp4xx/Kconfig
#
# Avila and IXDP share the same source for now. Will change in future
#
-Index: linux-2.6.21.1-armeb/arch/arm/mach-ixp4xx/Makefile
+Index: linux-2.6.21.7/arch/arm/mach-ixp4xx/Makefile
===================================================================
---- linux-2.6.21.1-armeb.orig/arch/arm/mach-ixp4xx/Makefile
-+++ linux-2.6.21.1-armeb/arch/arm/mach-ixp4xx/Makefile
-@@ -12,6 +12,7 @@
+--- linux-2.6.21.7.orig/arch/arm/mach-ixp4xx/Makefile
++++ linux-2.6.21.7/arch/arm/mach-ixp4xx/Makefile
+@@ -12,6 +12,7 @@ obj-pci-$(CONFIG_ARCH_ADI_COYOTE) += coy
obj-pci-$(CONFIG_MACH_GTWX5715) += gtwx5715-pci.o
obj-pci-$(CONFIG_MACH_NSLU2) += nslu2-pci.o
obj-pci-$(CONFIG_MACH_NAS100D) += nas100d-pci.o
@@ -56,17 +56,17 @@ Index: linux-2.6.21.1-armeb/arch/arm/mach-ixp4xx/Makefile
obj-y += common.o
-@@ -22,5 +23,6 @@
+@@ -22,5 +23,6 @@ obj-$(CONFIG_ARCH_ADI_COYOTE) += coyote-
obj-$(CONFIG_MACH_GTWX5715) += gtwx5715-setup.o
obj-$(CONFIG_MACH_NSLU2) += nslu2-setup.o nslu2-power.o
obj-$(CONFIG_MACH_NAS100D) += nas100d-setup.o nas100d-power.o
+obj-$(CONFIG_MACH_DSMG600) += dsmg600-setup.o dsmg600-power.o
obj-$(CONFIG_PCI) += $(obj-pci-$(CONFIG_PCI)) common-pci.o
-Index: linux-2.6.21.1-armeb/arch/arm/mach-ixp4xx/dsmg600-pci.c
+Index: linux-2.6.21.7/arch/arm/mach-ixp4xx/dsmg600-pci.c
===================================================================
--- /dev/null
-+++ linux-2.6.21.1-armeb/arch/arm/mach-ixp4xx/dsmg600-pci.c
++++ linux-2.6.21.7/arch/arm/mach-ixp4xx/dsmg600-pci.c
@@ -0,0 +1,74 @@
+/*
+ * DSM-G600 board-level PCI initialization
@@ -142,10 +142,10 @@ Index: linux-2.6.21.1-armeb/arch/arm/mach-ixp4xx/dsmg600-pci.c
+}
+
+subsys_initcall(dsmg600_pci_init);
-Index: linux-2.6.21.1-armeb/arch/arm/mach-ixp4xx/dsmg600-power.c
+Index: linux-2.6.21.7/arch/arm/mach-ixp4xx/dsmg600-power.c
===================================================================
--- /dev/null
-+++ linux-2.6.21.1-armeb/arch/arm/mach-ixp4xx/dsmg600-power.c
++++ linux-2.6.21.7/arch/arm/mach-ixp4xx/dsmg600-power.c
@@ -0,0 +1,130 @@
+/*
+ * arch/arm/mach-ixp4xx/dsmg600-power.c
@@ -277,10 +277,10 @@ Index: linux-2.6.21.1-armeb/arch/arm/mach-ixp4xx/dsmg600-power.c
+MODULE_AUTHOR("Michael Westerhof <mwester@dls.net>");
+MODULE_DESCRIPTION("DSM-G600 Power/Reset driver");
+MODULE_LICENSE("GPL");
-Index: linux-2.6.21.1-armeb/arch/arm/mach-ixp4xx/dsmg600-setup.c
+Index: linux-2.6.21.7/arch/arm/mach-ixp4xx/dsmg600-setup.c
===================================================================
--- /dev/null
-+++ linux-2.6.21.1-armeb/arch/arm/mach-ixp4xx/dsmg600-setup.c
++++ linux-2.6.21.7/arch/arm/mach-ixp4xx/dsmg600-setup.c
@@ -0,0 +1,175 @@
+/*
+ * DSM-G600 board-setup
@@ -457,10 +457,10 @@ Index: linux-2.6.21.1-armeb/arch/arm/mach-ixp4xx/dsmg600-setup.c
+ .timer = &ixp4xx_timer,
+ .init_machine = dsmg600_init,
+MACHINE_END
-Index: linux-2.6.21.1-armeb/include/asm-arm/arch-ixp4xx/dsmg600.h
+Index: linux-2.6.21.7/include/asm-arm/arch-ixp4xx/dsmg600.h
===================================================================
--- /dev/null
-+++ linux-2.6.21.1-armeb/include/asm-arm/arch-ixp4xx/dsmg600.h
++++ linux-2.6.21.7/include/asm-arm/arch-ixp4xx/dsmg600.h
@@ -0,0 +1,57 @@
+/*
+ * DSM-G600 platform specific definitions
@@ -519,21 +519,21 @@ Index: linux-2.6.21.1-armeb/include/asm-arm/arch-ixp4xx/dsmg600.h
+
+#define DSMG600_LED_WLAN_GPIO 14
+#define DSMG600_LED_WLAN_BM (1L << DSMG600_LED_WLAN_GPIO)
-Index: linux-2.6.21.1-armeb/include/asm-arm/arch-ixp4xx/hardware.h
+Index: linux-2.6.21.7/include/asm-arm/arch-ixp4xx/hardware.h
===================================================================
---- linux-2.6.21.1-armeb.orig/include/asm-arm/arch-ixp4xx/hardware.h
-+++ linux-2.6.21.1-armeb/include/asm-arm/arch-ixp4xx/hardware.h
-@@ -47,5 +47,6 @@
+--- linux-2.6.21.7.orig/include/asm-arm/arch-ixp4xx/hardware.h
++++ linux-2.6.21.7/include/asm-arm/arch-ixp4xx/hardware.h
+@@ -47,5 +47,6 @@ extern unsigned int processor_id;
#include "prpmc1100.h"
#include "nslu2.h"
#include "nas100d.h"
+#include "dsmg600.h"
#endif /* _ASM_ARCH_HARDWARE_H */
-Index: linux-2.6.21.1-armeb/include/asm-arm/arch-ixp4xx/irqs.h
+Index: linux-2.6.21.7/include/asm-arm/arch-ixp4xx/irqs.h
===================================================================
---- linux-2.6.21.1-armeb.orig/include/asm-arm/arch-ixp4xx/irqs.h
-+++ linux-2.6.21.1-armeb/include/asm-arm/arch-ixp4xx/irqs.h
+--- linux-2.6.21.7.orig/include/asm-arm/arch-ixp4xx/irqs.h
++++ linux-2.6.21.7/include/asm-arm/arch-ixp4xx/irqs.h
@@ -118,4 +118,14 @@
#define IRQ_NAS100D_PCI_INTD IRQ_IXP4XX_GPIO8
#define IRQ_NAS100D_PCI_INTE IRQ_IXP4XX_GPIO7