summaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/profiles
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/imx6/profiles')
-rw-r--r--target/linux/imx6/profiles/100-generic.mk (renamed from target/linux/imx6/profiles/100-Generic.mk)0
-rw-r--r--target/linux/imx6/profiles/110-wandboard.mk15
-rw-r--r--target/linux/imx6/profiles/120-gateworks.mk57
3 files changed, 72 insertions, 0 deletions
diff --git a/target/linux/imx6/profiles/100-Generic.mk b/target/linux/imx6/profiles/100-generic.mk
index 91ca3696ad..91ca3696ad 100644
--- a/target/linux/imx6/profiles/100-Generic.mk
+++ b/target/linux/imx6/profiles/100-generic.mk
diff --git a/target/linux/imx6/profiles/110-wandboard.mk b/target/linux/imx6/profiles/110-wandboard.mk
new file mode 100644
index 0000000000..4fa49ec6a6
--- /dev/null
+++ b/target/linux/imx6/profiles/110-wandboard.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/IMX6DL_WANDBOARD
+ NAME:=Wandboard Dual
+ PACKAGES:= \
+ kmod-thermal-imx kmod-usb-chipidea kmod-usb-mxs-phy \
+ uboot-envtools
+endef
+
+$(eval $(call Profile,IMX6DL_WANDBOARD))
diff --git a/target/linux/imx6/profiles/120-gateworks.mk b/target/linux/imx6/profiles/120-gateworks.mk
new file mode 100644
index 0000000000..9d43537ba7
--- /dev/null
+++ b/target/linux/imx6/profiles/120-gateworks.mk
@@ -0,0 +1,57 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/IMX6Q_GW5400_A
+ NAME:=Gateworks Ventana GW5400-A
+ PACKAGES:= \
+ kmod-thermal-imx kmod-usb-chipidea kmod-usb-mxs-phy
+endef
+
+define Profile/IMX6Q_GW5400_A/Description
+ The Gateworks GW5400-A family of products is based on the Freescale i.MX6Q SoC
+ and offers a large variety of peripherals such as:
+
+ * DDR3
+ * SPI FLASH
+ * 6x PCIe (3x with USB)
+ * Optional expansion for additional USB/PCI based periperhals
+ * 1x USB EHCI
+ * 1x USB OTG
+ * HDMI Audio/Video in/out
+ * Analog Video in/out
+ * Analog Audio in/out
+ * Gateworks System Controller
+endef
+
+$(eval $(call Profile,IMX6Q_GW5400_A))
+
+define Profile/IMX6Q_GW54XX
+ NAME:=Gateworks Ventana GW54XX
+ PACKAGES:= \
+ kmod-thermal-imx kmod-usb-chipidea kmod-usb-mxs-phy
+endef
+
+define Profile/IMX6Q_GW54XX/Description
+ The Gateworks GW54xx family of products is based on the Freescale i.MX6Q SoC
+ and offers a large variety of peripherals such as:
+
+ * DDR3
+ * NAND FLASH
+ * 6x PCIe (3x with USB)
+ * Optional expansion for additional USB/PCI based periperhals
+ * 1x USB EHCI
+ * 1x USB OTG
+ * HDMI Audio/Video in/out
+ * Analog Video in/out
+ * Analog Audio in/out
+ * Gateworks System Controller
+endef
+
+IMX6Q_GW54XX_UBIFS_OPTS:="-m 2048 -e 124KiB -c 1912"
+IMX6Q_GW54XX_UBI_OPTS:="-m 2048 -p 128KiB -s 2048"
+
+$(eval $(call Profile,IMX6Q_GW54XX))