summaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/imx6/image/Makefile')
-rw-r--r--target/linux/imx6/image/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index 2181ea5db4..6b66376d41 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -37,10 +37,16 @@ define Build/boot-overlay
--space-fixup --force-compr=zlib --squash-uids \
$(MKUBIFS_OPTS) -c 8124 \
-o $@.boot.ubifs -d $@.boot
+
+ $(TAR) -C $@.boot -cf $@.boot.tar .
endef
define Build/bootfs.tar.gz
- $(TAR) -C $(IMAGE_KERNEL).boot \
+ rm -rf $@.boot
+ mkdir -p $@.boot
+
+ $(TAR) -C $@.boot -xf $(IMAGE_KERNEL).boot.tar
+ $(TAR) -C $@.boot \
--numeric-owner --owner=0 --group=0 --transform "s,./,./boot/," \
-czvf $@ .
endef