summaryrefslogtreecommitdiffstats
path: root/target/linux/ifxmips/patches/170-crypto.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ifxmips/patches/170-crypto.patch')
-rw-r--r--target/linux/ifxmips/patches/170-crypto.patch81
1 files changed, 81 insertions, 0 deletions
diff --git a/target/linux/ifxmips/patches/170-crypto.patch b/target/linux/ifxmips/patches/170-crypto.patch
new file mode 100644
index 0000000000..e68da898e4
--- /dev/null
+++ b/target/linux/ifxmips/patches/170-crypto.patch
@@ -0,0 +1,81 @@
+Index: linux-2.6.35.8/drivers/crypto/Kconfig
+===================================================================
+--- linux-2.6.35.8.orig/drivers/crypto/Kconfig 2010-10-29 06:52:43.000000000 +0200
++++ linux-2.6.35.8/drivers/crypto/Kconfig 2010-11-01 11:36:03.000000000 +0100
+@@ -243,4 +243,66 @@
+ OMAP processors have SHA1/MD5 hw accelerator. Select this if you
+ want to use the OMAP module for SHA1/MD5 algorithms.
+
++config CRYPTO_DEV_IFXMIPS
++ bool "Support for IFXMIPS crypto engine"
++ select CRYPTO_ALGAPI
++ default y
++ help
++ Will support IFXMIPS crypto hardware
++ If you are unsure, say M.
++
++menuconfig CRYPTO_DEV_IFXMIPS_DES
++ bool "IFXMIPS crypto hardware for DES algorithm"
++ depends on CRYPTO_DEV_IFXMIPS
++ select CRYPTO_BLKCIPHER
++ default y
++ help
++ Use crypto hardware for DES/3DES algorithm.
++ If unsure say N.
++
++menuconfig CRYPTO_DEV_IFXMIPS_AES
++ bool "IFXMIPS crypto hardware for AES algorithm"
++ depends on CRYPTO_DEV_IFXMIPS
++ select CRYPTO_BLKCIPHER
++ default y
++ help
++ Use crypto hardware for AES algorithm.
++ If unsure say N.
++
++menuconfig CRYPTO_DEV_IFXMIPS_ARC4
++ bool "IFXMIPS crypto hardware for ARC4 algorithm"
++ depends on (CRYPTO_DEV_IFXMIPS && !DANUBE)
++ select CRYPTO_BLKCIPHER
++ default y
++ help
++ Use crypto hardware for ARC4 algorithm.
++ If unsure say N.
++
++menuconfig CRYPTO_DEV_IFXMIPS_SHA1
++ bool "IFXMIPS crypto hardware for SHA1 algorithm"
++ depends on CRYPTO_DEV_IFXMIPS
++ select CRYPTO_BLKCIPHER
++ default y
++ help
++ Use crypto hardware for SHA1 algorithm.
++ If unsure say N.
++
++menuconfig CRYPTO_DEV_IFXMIPS_SHA1_HMAC
++ bool "IFXMIPS crypto hardware for SHA1_HMAC algorithm"
++ depends on (CRYPTO_DEV_IFXMIPS && !DANUBE)
++ select CRYPTO_BLKCIPHER
++ default y
++ help
++ Use crypto hardware for SHA1_HMAC algorithm.
++ If unsure say N.
++
++menuconfig CRYPTO_DEV_IFXMIPS_MD5_HMAC
++ bool "IFXMIPS crypto hardware for MD5_HMAC algorithms"
++ depends on (CRYPTO_DEV_IFXMIPS && !DANUBE)
++ select CRYPTO_BLKCIPHER
++ default y
++ help
++ Use crypto hardware for MD5_HMAC algorithm.
++ If unsure say N.
++
+ endif # CRYPTO_HW
+Index: linux-2.6.35.8/drivers/crypto/Makefile
+===================================================================
+--- linux-2.6.35.8.orig/drivers/crypto/Makefile 2010-10-29 06:52:43.000000000 +0200
++++ linux-2.6.35.8/drivers/crypto/Makefile 2010-11-01 11:36:23.000000000 +0100
+@@ -9,4 +9,4 @@
+ obj-$(CONFIG_CRYPTO_DEV_IXP4XX) += ixp4xx_crypto.o
+ obj-$(CONFIG_CRYPTO_DEV_PPC4XX) += amcc/
+ obj-$(CONFIG_CRYPTO_DEV_OMAP_SHAM) += omap-sham.o
+-
++obj-$(CONFIG_CRYPTO_DEV_IFXMIPS) += ifxmips/