summaryrefslogtreecommitdiffstats
path: root/target/linux/generic
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic')
-rw-r--r--target/linux/generic/config-3.184
-rw-r--r--target/linux/generic/config-4.14
-rw-r--r--target/linux/generic/config-4.44
-rw-r--r--target/linux/generic/files/drivers/net/phy/b53/Kconfig22
-rw-r--r--target/linux/generic/files/drivers/net/phy/b53/Makefile14
-rw-r--r--target/linux/generic/patches-3.18/730-phy_b53.patch2
-rw-r--r--target/linux/generic/patches-4.1/730-phy_b53.patch2
-rw-r--r--target/linux/generic/patches-4.4/730-phy_b53.patch2
8 files changed, 27 insertions, 27 deletions
diff --git a/target/linux/generic/config-3.18 b/target/linux/generic/config-3.18
index 9185255db0..a2c81c2b29 100644
--- a/target/linux/generic/config-3.18
+++ b/target/linux/generic/config-3.18
@@ -330,8 +330,8 @@ CONFIG_ATM_CLIP_NO_ICMP=y
# CONFIG_B43 is not set
# CONFIG_B43LEGACY is not set
# CONFIG_B44 is not set
-# CONFIG_B53 is not set
-# CONFIG_B53_SPI_DRIVER is not set
+# CONFIG_SWCONFIG_B53 is not set
+# CONFIG_SWCONFIG_B53_SPI_DRIVER is not set
# CONFIG_BACKLIGHT_BD6107 is not set
# CONFIG_BACKLIGHT_GPIO is not set
# CONFIG_BACKLIGHT_LCD_SUPPORT is not set
diff --git a/target/linux/generic/config-4.1 b/target/linux/generic/config-4.1
index bdc4f1392e..fa95759a9c 100644
--- a/target/linux/generic/config-4.1
+++ b/target/linux/generic/config-4.1
@@ -344,8 +344,8 @@ CONFIG_ATM_CLIP_NO_ICMP=y
# CONFIG_B43 is not set
# CONFIG_B43LEGACY is not set
# CONFIG_B44 is not set
-# CONFIG_B53 is not set
-# CONFIG_B53_SPI_DRIVER is not set
+# CONFIG_SWCONFIG_B53 is not set
+# CONFIG_SWCONFIG_B53_SPI_DRIVER is not set
# CONFIG_BACKLIGHT_ADP8860 is not set
# CONFIG_BACKLIGHT_ADP8870 is not set
# CONFIG_BACKLIGHT_BD6107 is not set
diff --git a/target/linux/generic/config-4.4 b/target/linux/generic/config-4.4
index 1199cb5feb..54c4062459 100644
--- a/target/linux/generic/config-4.4
+++ b/target/linux/generic/config-4.4
@@ -321,8 +321,8 @@ CONFIG_ATM_CLIP_NO_ICMP=y
# CONFIG_B43 is not set
# CONFIG_B43LEGACY is not set
# CONFIG_B44 is not set
-# CONFIG_B53 is not set
-# CONFIG_B53_SPI_DRIVER is not set
+# CONFIG_SWCONFIG_B53 is not set
+# CONFIG_SWCONFIG_B53_SPI_DRIVER is not set
# CONFIG_BACKLIGHT_ADP8860 is not set
# CONFIG_BACKLIGHT_ADP8870 is not set
# CONFIG_BACKLIGHT_BD6107 is not set
diff --git a/target/linux/generic/files/drivers/net/phy/b53/Kconfig b/target/linux/generic/files/drivers/net/phy/b53/Kconfig
index 67e053ea0f..08287e7adf 100644
--- a/target/linux/generic/files/drivers/net/phy/b53/Kconfig
+++ b/target/linux/generic/files/drivers/net/phy/b53/Kconfig
@@ -1,4 +1,4 @@
-menuconfig B53
+menuconfig SWCONFIG_B53
tristate "Broadcom bcm53xx managed switch support"
depends on SWCONFIG
help
@@ -6,32 +6,32 @@ menuconfig B53
BCM5325E, BCM5365, BCM539x, BCM53115 and BCM53125 as well as BCM63XX
integrated switches.
-config B53_SPI_DRIVER
+config SWCONFIG_B53_SPI_DRIVER
tristate "B53 SPI connected switch driver"
- depends on B53 && SPI
+ depends on SWCONFIG_B53 && SPI
help
Select to enable support for registering switches configured through SPI.
-config B53_PHY_DRIVER
+config SWCONFIG_B53_PHY_DRIVER
tristate "B53 MDIO connected switch driver"
- depends on B53
- select B53_PHY_FIXUP
+ depends on SWCONFIG_B53
+ select SWCONFIG_B53_PHY_FIXUP
help
Select to enable support for registering switches configured through MDIO.
-config B53_MMAP_DRIVER
+config SWCONFIG_B53_MMAP_DRIVER
tristate "B53 MMAP connected switch driver"
- depends on B53
+ depends on SWCONFIG_B53
help
Select to enable support for memory-mapped switches like the BCM63XX
integrated switches.
-config B53_SRAB_DRIVER
+config SWCONFIG_B53_SRAB_DRIVER
tristate "B53 SRAB connected switch driver"
- depends on B53
+ depends on SWCONFIG_B53
help
Select to enable support for memory-mapped Switch Register Access
Bridge Registers (SRAB) like it is found on the BCM53010
-config B53_PHY_FIXUP
+config SWCONFIG_B53_PHY_FIXUP
bool
diff --git a/target/linux/generic/files/drivers/net/phy/b53/Makefile b/target/linux/generic/files/drivers/net/phy/b53/Makefile
index 7cc39c7628..13ff366448 100644
--- a/target/linux/generic/files/drivers/net/phy/b53/Makefile
+++ b/target/linux/generic/files/drivers/net/phy/b53/Makefile
@@ -1,10 +1,10 @@
-obj-$(CONFIG_B53) += b53_common.o
+obj-$(CONFIG_SWCONFIG_B53) += b53_common.o
-obj-$(CONFIG_B53_PHY_FIXUP) += b53_phy_fixup.o
+obj-$(CONFIG_SWCONFIG_B53_PHY_FIXUP) += b53_phy_fixup.o
-obj-$(CONFIG_B53_MMAP_DRIVER) += b53_mmap.o
-obj-$(CONFIG_B53_SRAB_DRIVER) += b53_srab.o
-obj-$(CONFIG_B53_PHY_DRIVER) += b53_mdio.o
-obj-$(CONFIG_B53_SPI_DRIVER) += b53_spi.o
+obj-$(CONFIG_SWCONFIG_B53_MMAP_DRIVER) += b53_mmap.o
+obj-$(CONFIG_SWCONFIG_B53_SRAB_DRIVER) += b53_srab.o
+obj-$(CONFIG_SWCONFIG_B53_PHY_DRIVER) += b53_mdio.o
+obj-$(CONFIG_SWCONFIG_B53_SPI_DRIVER) += b53_spi.o
-ccflags-y += -Werror
+ccflags-y += -Werror
diff --git a/target/linux/generic/patches-3.18/730-phy_b53.patch b/target/linux/generic/patches-3.18/730-phy_b53.patch
index c2dfcfa501..03fc369c9d 100644
--- a/target/linux/generic/patches-3.18/730-phy_b53.patch
+++ b/target/linux/generic/patches-3.18/730-phy_b53.patch
@@ -15,7 +15,7 @@
obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
obj-$(CONFIG_PSB6970_PHY) += psb6970.o
-+obj-$(CONFIG_B53) += b53/
++obj-$(CONFIG_SWCONFIG_B53) += b53/
obj-$(CONFIG_FIXED_PHY) += fixed.o
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o
diff --git a/target/linux/generic/patches-4.1/730-phy_b53.patch b/target/linux/generic/patches-4.1/730-phy_b53.patch
index bdcfba6e86..ff166890d4 100644
--- a/target/linux/generic/patches-4.1/730-phy_b53.patch
+++ b/target/linux/generic/patches-4.1/730-phy_b53.patch
@@ -15,7 +15,7 @@
obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
obj-$(CONFIG_PSB6970_PHY) += psb6970.o
-+obj-$(CONFIG_B53) += b53/
++obj-$(CONFIG_SWCONFIG_B53) += b53/
obj-$(CONFIG_FIXED_PHY) += fixed_phy.o
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o
diff --git a/target/linux/generic/patches-4.4/730-phy_b53.patch b/target/linux/generic/patches-4.4/730-phy_b53.patch
index 71a53fded4..1a6de96726 100644
--- a/target/linux/generic/patches-4.4/730-phy_b53.patch
+++ b/target/linux/generic/patches-4.4/730-phy_b53.patch
@@ -15,7 +15,7 @@
obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
obj-$(CONFIG_PSB6970_PHY) += psb6970.o
-+obj-$(CONFIG_B53) += b53/
++obj-$(CONFIG_SWCONFIG_B53) += b53/
obj-$(CONFIG_FIXED_PHY) += fixed_phy.o
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o