summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.4/835-misc-owl_loader.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-4.4/835-misc-owl_loader.patch')
-rw-r--r--target/linux/generic/patches-4.4/835-misc-owl_loader.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.4/835-misc-owl_loader.patch b/target/linux/generic/patches-4.4/835-misc-owl_loader.patch
new file mode 100644
index 0000000000..bbf19c093d
--- /dev/null
+++ b/target/linux/generic/patches-4.4/835-misc-owl_loader.patch
@@ -0,0 +1,31 @@
+--- a/drivers/misc/Kconfig 2016-09-18 15:23:07.100190724 +0200
++++ b/drivers/misc/Kconfig 2016-09-18 15:26:56.130785350 +0200
+@@ -150,6 +150,18 @@ config SGI_IOC4
+ If you have an SGI Altix with an IOC4-based card say Y.
+ Otherwise say N.
+
++config OWL_LOADER
++ tristate "Owl loader for initializing Atheros PCI(e) Wifi chips"
++ depends on PCI
++ ---help---
++ This kernel module helps to initialize certain Qualcomm
++ Atheros' PCI(e) Wifi chips, which have the init data
++ (which contains the PCI device ID for example) stored
++ together with the calibration data in the file system.
++
++ This is necessary for devices like the Cisco Meraki Z1, say M.
++ Otherwise say N.
++
+ config TIFM_CORE
+ tristate "TI Flash Media interface support"
+ depends on PCI
+--- a/drivers/misc/Makefile 2016-09-18 15:21:56.406675181 +0200
++++ b/drivers/misc/Makefile 2016-09-18 15:22:46.866805239 +0200
+@@ -15,6 +15,7 @@ obj-$(CONFIG_BMP085_SPI) += bmp085-spi.o
+ obj-$(CONFIG_DUMMY_IRQ) += dummy-irq.o
+ obj-$(CONFIG_ICS932S401) += ics932s401.o
+ obj-$(CONFIG_LKDTM) += lkdtm.o
++obj-$(CONFIG_OWL_LOADER) += owl-loader.o
+ obj-$(CONFIG_TIFM_CORE) += tifm_core.o
+ obj-$(CONFIG_TIFM_7XX1) += tifm_7xx1.o
+ obj-$(CONFIG_PHANTOM) += phantom.o