summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.7/865-gpiopwm.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-3.7/865-gpiopwm.patch')
-rw-r--r--target/linux/generic/patches-3.7/865-gpiopwm.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.7/865-gpiopwm.patch b/target/linux/generic/patches-3.7/865-gpiopwm.patch
new file mode 100644
index 0000000000..f899d1a63a
--- /dev/null
+++ b/target/linux/generic/patches-3.7/865-gpiopwm.patch
@@ -0,0 +1,21 @@
+--- a/drivers/Kconfig
++++ b/drivers/Kconfig
+@@ -62,6 +62,8 @@ source "drivers/pinctrl/Kconfig"
+
+ source "drivers/gpio/Kconfig"
+
++source "drivers/pwm/Kconfig"
++
+ source "drivers/w1/Kconfig"
+
+ source "drivers/power/Kconfig"
+--- a/drivers/Makefile
++++ b/drivers/Makefile
+@@ -13,6 +13,7 @@ obj-y += pinctrl/
+ obj-y += gpio/
+ obj-y += pwm/
+ obj-$(CONFIG_PCI) += pci/
++obj-$(CONFIG_GENERIC_PWM) += pwm/
+ obj-$(CONFIG_PARISC) += parisc/
+ obj-$(CONFIG_RAPIDIO) += rapidio/
+ obj-y += video/