summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.7/728-phy-micrel.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-3.7/728-phy-micrel.patch')
-rw-r--r--target/linux/generic/patches-3.7/728-phy-micrel.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.7/728-phy-micrel.patch b/target/linux/generic/patches-3.7/728-phy-micrel.patch
new file mode 100644
index 0000000000..6172e236f5
--- /dev/null
+++ b/target/linux/generic/patches-3.7/728-phy-micrel.patch
@@ -0,0 +1,24 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -145,6 +145,11 @@ config RTL8306_PHY
+ tristate "Driver for Realtek RTL8306S switches"
+ select SWCONFIG
+
++config MICREL_PHY
++ tristate "Drivers for Micrel/Kendin PHYs"
++ ---help---
++ Currently has a driver for the KSZ8041
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -28,6 +28,7 @@ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
+ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
++obj-$(CONFIG_MICREL_PHY) += micrel.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+ obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o