summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.37
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-2.6.37')
-rw-r--r--target/linux/generic/patches-2.6.37/012-extra_optimization.patch4
-rw-r--r--target/linux/generic/patches-2.6.37/030-pci_disable_common_quirks.patch8
-rw-r--r--target/linux/generic/patches-2.6.37/801-usb_serial_endpoint_size.patch13
-rw-r--r--target/linux/generic/patches-2.6.37/980-vm_exports.patch3
4 files changed, 15 insertions, 13 deletions
diff --git a/target/linux/generic/patches-2.6.37/012-extra_optimization.patch b/target/linux/generic/patches-2.6.37/012-extra_optimization.patch
index 4ffa26e9eb..a7811d78fc 100644
--- a/target/linux/generic/patches-2.6.37/012-extra_optimization.patch
+++ b/target/linux/generic/patches-2.6.37/012-extra_optimization.patch
@@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
-@@ -538,9 +538,9 @@
+@@ -538,9 +538,9 @@ endif # $(dot-config)
all: vmlinux
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
@@ -12,7 +12,7 @@
endif
include $(srctree)/arch/$(SRCARCH)/Makefile
-@@ -595,6 +595,9 @@
+@@ -595,6 +595,9 @@ endif
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
diff --git a/target/linux/generic/patches-2.6.37/030-pci_disable_common_quirks.patch b/target/linux/generic/patches-2.6.37/030-pci_disable_common_quirks.patch
index a951437102..4627986390 100644
--- a/target/linux/generic/patches-2.6.37/030-pci_disable_common_quirks.patch
+++ b/target/linux/generic/patches-2.6.37/030-pci_disable_common_quirks.patch
@@ -23,7 +23,7 @@
/* The Mellanox Tavor device gives false positive parity errors
* Mark this device with a broken_parity_status, to allow
* PCI scanning code to "skip" this now blacklisted device.
-@@ -1944,7 +1945,9 @@ static void __devinit fixup_rev1_53c810(
+@@ -1989,7 +1990,9 @@ static void __devinit fixup_rev1_53c810(
}
}
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_NCR, PCI_DEVICE_ID_NCR_53C810, fixup_rev1_53c810);
@@ -33,10 +33,10 @@
/* Enable 1k I/O space granularity on the Intel P64H2 */
static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev)
{
-@@ -2669,6 +2672,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
- DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x1518, quirk_i82576_sriov);
+@@ -2662,6 +2665,7 @@ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_AT
+ quirk_msi_intx_disable_bug);
- #endif /* CONFIG_PCI_IOV */
+ #endif /* CONFIG_PCI_MSI */
+#endif /* !CONFIG_PCI_DISABLE_COMMON_QUIRKS */
/* Allow manual resource allocation for PCI hotplug bridges
diff --git a/target/linux/generic/patches-2.6.37/801-usb_serial_endpoint_size.patch b/target/linux/generic/patches-2.6.37/801-usb_serial_endpoint_size.patch
index 3725b922ce..1646fdf1b1 100644
--- a/target/linux/generic/patches-2.6.37/801-usb_serial_endpoint_size.patch
+++ b/target/linux/generic/patches-2.6.37/801-usb_serial_endpoint_size.patch
@@ -8,16 +8,17 @@
static int debug;
/* initially all NULL */
static struct usb_serial *serial_table[SERIAL_TTY_MINORS];
-@@ -913,7 +914,7 @@ int usb_serial_probe(struct usb_interfac
+@@ -912,7 +913,8 @@ int usb_serial_probe(struct usb_interfac
+ goto probe_error;
}
- buffer_size = serial->type->bulk_in_size;
- if (!buffer_size)
-- buffer_size = le16_to_cpu(endpoint->wMaxPacketSize);
-+ buffer_size = (endpoint->wMaxPacketSize > maxSize) ? endpoint->wMaxPacketSize : maxSize;
+ buffer_size = max_t(int, serial->type->bulk_in_size,
+- le16_to_cpu(endpoint->wMaxPacketSize));
++ max_t(int, le16_to_cpu(endpoint->wMaxPacketSize),
++ maxSize));
port->bulk_in_size = buffer_size;
port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
-@@ -1392,3 +1393,5 @@ MODULE_LICENSE("GPL");
+@@ -1391,3 +1393,5 @@ MODULE_LICENSE("GPL");
module_param(debug, bool, S_IRUGO | S_IWUSR);
MODULE_PARM_DESC(debug, "Debug enabled or not");
diff --git a/target/linux/generic/patches-2.6.37/980-vm_exports.patch b/target/linux/generic/patches-2.6.37/980-vm_exports.patch
index 2a965b22fd..ce49106660 100644
--- a/target/linux/generic/patches-2.6.37/980-vm_exports.patch
+++ b/target/linux/generic/patches-2.6.37/980-vm_exports.patch
@@ -25,7 +25,7 @@
/**
* shmem_file_setup - get an unlinked file living in tmpfs
* @name: name for dentry (to be seen in /proc/<pid>/maps
-@@ -2780,9 +2791,6 @@ int shmem_zero_setup(struct vm_area_stru
+@@ -2780,10 +2791,7 @@ int shmem_zero_setup(struct vm_area_stru
if (IS_ERR(file))
return PTR_ERR(file);
@@ -34,6 +34,7 @@
- vma->vm_file = file;
- vma->vm_ops = &shmem_vm_ops;
+ shmem_set_file(vma, file);
+ vma->vm_flags |= VM_CAN_NONLINEAR;
return 0;
}
--- a/fs/file.c