summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.32/055-lzma_arm_kernel.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-2.6.32/055-lzma_arm_kernel.patch')
-rw-r--r--target/linux/generic/patches-2.6.32/055-lzma_arm_kernel.patch57
1 files changed, 0 insertions, 57 deletions
diff --git a/target/linux/generic/patches-2.6.32/055-lzma_arm_kernel.patch b/target/linux/generic/patches-2.6.32/055-lzma_arm_kernel.patch
deleted file mode 100644
index a0111bd554..0000000000
--- a/target/linux/generic/patches-2.6.32/055-lzma_arm_kernel.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From d0f226a0f104c7d1da1d215b8013359273e39e18 Mon Sep 17 00:00:00 2001
-From: Albin Tonnerre <albin.tonnerre@free-electrons.com>
-Date: Fri, 16 Oct 2009 16:17:22 +0200
-Subject: [PATCH] Add LZMA decompression on ARM
-
-
-Signed-off-by: Albin Tonnerre <albin.tonnerre@free-electrons.com>
----
- arch/arm/Kconfig | 1 +
- arch/arm/boot/compressed/Makefile | 1 +
- arch/arm/boot/compressed/misc.c | 4 ++++
- arch/arm/boot/compressed/piggy.lzma.S | 6 ++++++
- 4 files changed, 12 insertions(+), 0 deletions(-)
- create mode 100644 arch/arm/boot/compressed/piggy.lzma.S
-
---- a/arch/arm/Kconfig
-+++ b/arch/arm/Kconfig
-@@ -20,6 +20,7 @@ config ARM
- select HAVE_GENERIC_DMA_COHERENT
- select HAVE_KERNEL_GZIP
- select HAVE_KERNEL_LZO
-+ select HAVE_KERNEL_LZMA
- help
- The ARM series is a line of low-power-consumption RISC chip designs
- licensed by ARM Ltd and targeted at embedded applications and
---- a/arch/arm/boot/compressed/Makefile
-+++ b/arch/arm/boot/compressed/Makefile
-@@ -65,6 +65,7 @@ SEDFLAGS = s/TEXT_START/$(ZTEXTADDR)/;s/
-
- suffix_$(CONFIG_KERNEL_GZIP) = gzip
- suffix_$(CONFIG_KERNEL_LZO) = lzo
-+suffix_$(CONFIG_KERNEL_LZMA) = lzma
-
- targets := vmlinux vmlinux.lds \
- piggy.$(suffix_y) piggy.$(suffix_y).o \
---- a/arch/arm/boot/compressed/misc.c
-+++ b/arch/arm/boot/compressed/misc.c
-@@ -237,6 +237,10 @@ static unsigned long free_mem_end_ptr;
- #include "../../../../lib/decompress_inflate.c"
- #endif
-
-+#ifdef CONFIG_KERNEL_LZMA
-+#include "../../../../lib/decompress_unlzma.c"
-+#endif
-+
- #ifdef CONFIG_KERNEL_LZO
- #include "../../../../lib/decompress_unlzo.c"
- #endif
---- /dev/null
-+++ b/arch/arm/boot/compressed/piggy.lzma.S
-@@ -0,0 +1,6 @@
-+ .section .piggydata,#alloc
-+ .globl input_data
-+input_data:
-+ .incbin "arch/arm/boot/compressed/piggy.lzma"
-+ .globl input_data_end
-+input_data_end: