summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic-2.6')
-rw-r--r--target/linux/generic-2.6/patches-2.6.31/020-mips_multi_machine_support.patch2
-rw-r--r--target/linux/generic-2.6/patches-2.6.31/032-mips_vmlinux_lds.patch30
-rw-r--r--target/linux/generic-2.6/patches-2.6.31/049-byteshift_h_fix_usage_for_compressed_kernels.patch7
-rw-r--r--target/linux/generic-2.6/patches-2.6.31/050-lzo_compressed_kernels.patch12
-rw-r--r--target/linux/generic-2.6/patches-2.6.31/051-lzo_compressed_kernel_for_arm.patch19
-rw-r--r--target/linux/generic-2.6/patches-2.6.31/052-lzo_compressed_kernel_for_x86.patch8
-rw-r--r--target/linux/generic-2.6/patches-2.6.31/053-lzo_compression_for_initramfs.patch14
-rw-r--r--target/linux/generic-2.6/patches-2.6.31/055-lzma_arm_kernel.patch14
-rw-r--r--target/linux/generic-2.6/patches-2.6.31/270-sched_bfs.patch4
-rw-r--r--target/linux/generic-2.6/patches-2.6.31/977-textsearch_kconfig_hacks.patch2
-rw-r--r--target/linux/generic-2.6/patches-2.6.31/998-openwrt_lzma_options.patch4
11 files changed, 17 insertions, 99 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.31/020-mips_multi_machine_support.patch b/target/linux/generic-2.6/patches-2.6.31/020-mips_multi_machine_support.patch
index f36ae38557..5c70b548ac 100644
--- a/target/linux/generic-2.6/patches-2.6.31/020-mips_multi_machine_support.patch
+++ b/target/linux/generic-2.6/patches-2.6.31/020-mips_multi_machine_support.patch
@@ -122,7 +122,7 @@
+
--- a/arch/mips/kernel/Makefile
+++ b/arch/mips/kernel/Makefile
-@@ -85,6 +85,7 @@ obj-$(CONFIG_GPIO_TXX9) += gpio_txx9.o
+@@ -87,6 +87,7 @@ obj-$(CONFIG_GPIO_TXX9) += gpio_txx9.o
obj-$(CONFIG_KEXEC) += machine_kexec.o relocate_kernel.o
obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
diff --git a/target/linux/generic-2.6/patches-2.6.31/032-mips_vmlinux_lds.patch b/target/linux/generic-2.6/patches-2.6.31/032-mips_vmlinux_lds.patch
index 2ecf89dde0..807a9444f4 100644
--- a/target/linux/generic-2.6/patches-2.6.31/032-mips_vmlinux_lds.patch
+++ b/target/linux/generic-2.6/patches-2.6.31/032-mips_vmlinux_lds.patch
@@ -1,35 +1,11 @@
--- a/arch/mips/kernel/Makefile
+++ b/arch/mips/kernel/Makefile
-@@ -2,6 +2,8 @@
- # Makefile for the Linux/MIPS kernel.
- #
+@@ -4,6 +4,8 @@
+
+ CPPFLAGS_vmlinux.lds := $(KBUILD_CFLAGS)
+CPPFLAGS_vmlinux.lds := $(KBUILD_CFLAGS) $(EXTRA_LDSFLAGS)
+
extra-y := head.o init_task.o vmlinux.lds
obj-y += cpu-probe.o branch.o entry.o genex.o irq.o process.o \
---- a/arch/mips/kernel/vmlinux.lds.S
-+++ b/arch/mips/kernel/vmlinux.lds.S
-@@ -10,15 +10,15 @@ PHDRS {
- note PT_NOTE FLAGS(4); /* R__ */
- }
-
--ifdef CONFIG_32BIT
-- ifdef CONFIG_CPU_LITTLE_ENDIAN
-+#ifdef CONFIG_32BIT
-+ #ifdef CONFIG_CPU_LITTLE_ENDIAN
- jiffies = jiffies_64;
-- else
-+ #else
- jiffies = jiffies_64 + 4;
-- endif
--else
-+ #endif
-+#else
- jiffies = jiffies_64;
--endif
-+#endif
-
- SECTIONS
- {
diff --git a/target/linux/generic-2.6/patches-2.6.31/049-byteshift_h_fix_usage_for_compressed_kernels.patch b/target/linux/generic-2.6/patches-2.6.31/049-byteshift_h_fix_usage_for_compressed_kernels.patch
index 102a829828..5cd81070e1 100644
--- a/target/linux/generic-2.6/patches-2.6.31/049-byteshift_h_fix_usage_for_compressed_kernels.patch
+++ b/target/linux/generic-2.6/patches-2.6.31/049-byteshift_h_fix_usage_for_compressed_kernels.patch
@@ -48,8 +48,6 @@ Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
include/linux/unaligned/le_byteshift.h | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
-diff --git a/include/linux/unaligned/be_byteshift.h b/include/linux/unaligned/be_byteshift.h
-index 46dd12c..9356b24 100644
--- a/include/linux/unaligned/be_byteshift.h
+++ b/include/linux/unaligned/be_byteshift.h
@@ -1,7 +1,7 @@
@@ -61,8 +59,6 @@ index 46dd12c..9356b24 100644
static inline u16 __get_unaligned_be16(const u8 *p)
{
-diff --git a/include/linux/unaligned/le_byteshift.h b/include/linux/unaligned/le_byteshift.h
-index 59777e9..be376fb 100644
--- a/include/linux/unaligned/le_byteshift.h
+++ b/include/linux/unaligned/le_byteshift.h
@@ -1,7 +1,7 @@
@@ -74,6 +70,3 @@ index 59777e9..be376fb 100644
static inline u16 __get_unaligned_le16(const u8 *p)
{
---
-1.6.5.1
-
diff --git a/target/linux/generic-2.6/patches-2.6.31/050-lzo_compressed_kernels.patch b/target/linux/generic-2.6/patches-2.6.31/050-lzo_compressed_kernels.patch
index fad1b87466..733d1756f6 100644
--- a/target/linux/generic-2.6/patches-2.6.31/050-lzo_compressed_kernels.patch
+++ b/target/linux/generic-2.6/patches-2.6.31/050-lzo_compressed_kernels.patch
@@ -1,6 +1,3 @@
-diff --git a/include/linux/decompress/unlzo.h b/include/linux/decompress/unlzo.h
-new file mode 100644
-index 0000000..9872297
--- /dev/null
+++ b/include/linux/decompress/unlzo.h
@@ -0,0 +1,10 @@
@@ -14,8 +11,6 @@ index 0000000..9872297
+ int *pos,
+ void(*error)(char *x));
+#endif
-diff --git a/init/Kconfig b/init/Kconfig
-index f515864..eb65318 100644
--- a/init/Kconfig
+++ b/init/Kconfig
@@ -115,10 +115,13 @@ config HAVE_KERNEL_BZIP2
@@ -60,9 +55,6 @@ index f515864..eb65318 100644
endchoice
config SWAP
-diff --git a/lib/decompress_unlzo.c b/lib/decompress_unlzo.c
-new file mode 100644
-index 0000000..2bb736f
--- /dev/null
+++ b/lib/decompress_unlzo.c
@@ -0,0 +1,208 @@
@@ -274,8 +266,6 @@ index 0000000..2bb736f
+}
+
+#define decompress unlzo
-diff --git a/lib/lzo/lzo1x_decompress.c b/lib/lzo/lzo1x_decompress.c
-index 5dc6b29..f2fd098 100644
--- a/lib/lzo/lzo1x_decompress.c
+++ b/lib/lzo/lzo1x_decompress.c
@@ -11,11 +11,13 @@
@@ -306,8 +296,6 @@ index 5dc6b29..f2fd098 100644
MODULE_DESCRIPTION("LZO1X Decompressor");
+#endif
-diff --git a/scripts/Makefile.lib b/scripts/Makefile.lib
-index ffdafb2..39c3483 100644
--- a/scripts/Makefile.lib
+++ b/scripts/Makefile.lib
@@ -230,3 +230,8 @@ quiet_cmd_lzma = LZMA $@
diff --git a/target/linux/generic-2.6/patches-2.6.31/051-lzo_compressed_kernel_for_arm.patch b/target/linux/generic-2.6/patches-2.6.31/051-lzo_compressed_kernel_for_arm.patch
index f155c0a1b5..49512bb41d 100644
--- a/target/linux/generic-2.6/patches-2.6.31/051-lzo_compressed_kernel_for_arm.patch
+++ b/target/linux/generic-2.6/patches-2.6.31/051-lzo_compressed_kernel_for_arm.patch
@@ -1,5 +1,3 @@
-diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
-index 1c4119c..350921d 100644
--- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig
@@ -18,6 +18,8 @@ config ARM
@@ -11,8 +9,6 @@ index 1c4119c..350921d 100644
help
The ARM series is a line of low-power-consumption RISC chip designs
licensed by ARM Ltd and targeted at embedded applications and
-diff --git a/arch/arm/boot/compressed/Makefile b/arch/arm/boot/compressed/Makefile
-index ce39dc5..5b4629b 100644
--- a/arch/arm/boot/compressed/Makefile
+++ b/arch/arm/boot/compressed/Makefile
@@ -63,8 +63,12 @@ endif
@@ -69,8 +65,6 @@ index ce39dc5..5b4629b 100644
CFLAGS_font.o := -Dstatic=
-diff --git a/arch/arm/boot/compressed/misc.c b/arch/arm/boot/compressed/misc.c
-index 17153b5..7e0fe4d 100644
--- a/arch/arm/boot/compressed/misc.c
+++ b/arch/arm/boot/compressed/misc.c
@@ -18,10 +18,15 @@
@@ -89,7 +83,7 @@ index 17153b5..7e0fe4d 100644
#ifdef STANDALONE_DEBUG
#define putstr printf
-@@ -188,34 +193,8 @@ static inline __ptr_t memcpy(__ptr_t __dest, __const __ptr_t __src,
+@@ -188,34 +193,8 @@ static inline __ptr_t memcpy(__ptr_t __d
/*
* gzip delarations
*/
@@ -124,7 +118,7 @@ index 17153b5..7e0fe4d 100644
/* Diagnostic functions */
#ifdef DEBUG
# define Assert(cond,msg) {if(!(cond)) error(msg);}
-@@ -233,24 +212,20 @@ static unsigned outcnt; /* bytes in output buffer */
+@@ -233,24 +212,20 @@ static unsigned outcnt; /* bytes in out
# define Tracecv(c,x)
#endif
@@ -260,9 +254,6 @@ index 17153b5..7e0fe4d 100644
}
#endif
-
-diff --git a/arch/arm/boot/compressed/piggy.S b/arch/arm/boot/compressed/piggy.S
-deleted file mode 100644
-index 54c9518..0000000
--- a/arch/arm/boot/compressed/piggy.S
+++ /dev/null
@@ -1,6 +0,0 @@
@@ -272,9 +263,6 @@ index 54c9518..0000000
- .incbin "arch/arm/boot/compressed/piggy.gz"
- .globl input_data_end
-input_data_end:
-diff --git a/arch/arm/boot/compressed/piggy.gzip.S b/arch/arm/boot/compressed/piggy.gzip.S
-new file mode 100644
-index 0000000..a68adf9
--- /dev/null
+++ b/arch/arm/boot/compressed/piggy.gzip.S
@@ -0,0 +1,6 @@
@@ -284,9 +272,6 @@ index 0000000..a68adf9
+ .incbin "arch/arm/boot/compressed/piggy.gzip"
+ .globl input_data_end
+input_data_end:
-diff --git a/arch/arm/boot/compressed/piggy.lzo.S b/arch/arm/boot/compressed/piggy.lzo.S
-new file mode 100644
-index 0000000..a425ad9
--- /dev/null
+++ b/arch/arm/boot/compressed/piggy.lzo.S
@@ -0,0 +1,6 @@
diff --git a/target/linux/generic-2.6/patches-2.6.31/052-lzo_compressed_kernel_for_x86.patch b/target/linux/generic-2.6/patches-2.6.31/052-lzo_compressed_kernel_for_x86.patch
index bfefe8bfde..ea7d2400ba 100644
--- a/target/linux/generic-2.6/patches-2.6.31/052-lzo_compressed_kernel_for_x86.patch
+++ b/target/linux/generic-2.6/patches-2.6.31/052-lzo_compressed_kernel_for_x86.patch
@@ -1,5 +1,3 @@
-diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
-index 72ace95..89f7771 100644
--- a/arch/x86/Kconfig
+++ b/arch/x86/Kconfig
@@ -49,6 +49,7 @@ config X86
@@ -10,8 +8,6 @@ index 72ace95..89f7771 100644
select HAVE_ARCH_KMEMCHECK
config OUTPUT_FORMAT
-diff --git a/arch/x86/boot/compressed/Makefile b/arch/x86/boot/compressed/Makefile
-index f8ed065..0e835d0 100644
--- a/arch/x86/boot/compressed/Makefile
+++ b/arch/x86/boot/compressed/Makefile
@@ -4,7 +4,7 @@
@@ -23,7 +19,7 @@ index f8ed065..0e835d0 100644
KBUILD_CFLAGS := -m$(BITS) -D__KERNEL__ $(LINUX_INCLUDE) -O2
KBUILD_CFLAGS += -fno-strict-aliasing -fPIC
-@@ -48,10 +48,13 @@ $(obj)/vmlinux.bin.bz2: $(vmlinux.bin.all-y) FORCE
+@@ -48,10 +48,13 @@ $(obj)/vmlinux.bin.bz2: $(vmlinux.bin.al
$(call if_changed,bzip2)
$(obj)/vmlinux.bin.lzma: $(vmlinux.bin.all-y) FORCE
$(call if_changed,lzma)
@@ -37,8 +33,6 @@ index f8ed065..0e835d0 100644
quiet_cmd_mkpiggy = MKPIGGY $@
cmd_mkpiggy = $(obj)/mkpiggy $< > $@ || ( rm -f $@ ; false )
-diff --git a/arch/x86/boot/compressed/misc.c b/arch/x86/boot/compressed/misc.c
-index 842b2a3..3b22fe8 100644
--- a/arch/x86/boot/compressed/misc.c
+++ b/arch/x86/boot/compressed/misc.c
@@ -162,6 +162,10 @@ static int lines, cols;
diff --git a/target/linux/generic-2.6/patches-2.6.31/053-lzo_compression_for_initramfs.patch b/target/linux/generic-2.6/patches-2.6.31/053-lzo_compression_for_initramfs.patch
index f0d8ff39f9..3445b4ae98 100644
--- a/target/linux/generic-2.6/patches-2.6.31/053-lzo_compression_for_initramfs.patch
+++ b/target/linux/generic-2.6/patches-2.6.31/053-lzo_compression_for_initramfs.patch
@@ -1,10 +1,8 @@
-diff --git a/lib/Kconfig b/lib/Kconfig
-index bb1326d..8639349 100644
--- a/lib/Kconfig
+++ b/lib/Kconfig
-@@ -117,6 +117,10 @@ config DECOMPRESS_BZIP2
- config DECOMPRESS_LZMA
- tristate
+@@ -120,6 +120,10 @@ config DECOMPRESS_LZMA
+ config DECOMPRESS_LZMA_NEEDED
+ boolean
+config DECOMPRESS_LZO
+ select LZO_DECOMPRESS
@@ -13,8 +11,6 @@ index bb1326d..8639349 100644
#
# Generic allocator support is selected if needed
#
-diff --git a/lib/Makefile b/lib/Makefile
-index 2e78277..cfa4041 100644
--- a/lib/Makefile
+++ b/lib/Makefile
@@ -69,6 +69,7 @@ obj-$(CONFIG_LZO_DECOMPRESS) += lzo/
@@ -25,8 +21,6 @@ index 2e78277..cfa4041 100644
obj-$(CONFIG_TEXTSEARCH) += textsearch.o
obj-$(CONFIG_TEXTSEARCH_KMP) += ts_kmp.o
-diff --git a/lib/decompress.c b/lib/decompress.c
-index d2842f5..a760681 100644
--- a/lib/decompress.c
+++ b/lib/decompress.c
@@ -9,6 +9,7 @@
@@ -55,8 +49,6 @@ index d2842f5..a760681 100644
{ {0, 0}, NULL, NULL }
};
-diff --git a/usr/Kconfig b/usr/Kconfig
-index 1c3039f..e2721f5 100644
--- a/usr/Kconfig
+++ b/usr/Kconfig
@@ -72,6 +72,15 @@ config RD_LZMA
diff --git a/target/linux/generic-2.6/patches-2.6.31/055-lzma_arm_kernel.patch b/target/linux/generic-2.6/patches-2.6.31/055-lzma_arm_kernel.patch
index 1f39628929..a0111bd554 100644
--- a/target/linux/generic-2.6/patches-2.6.31/055-lzma_arm_kernel.patch
+++ b/target/linux/generic-2.6/patches-2.6.31/055-lzma_arm_kernel.patch
@@ -13,8 +13,6 @@ Signed-off-by: Albin Tonnerre <albin.tonnerre@free-electrons.com>
4 files changed, 12 insertions(+), 0 deletions(-)
create mode 100644 arch/arm/boot/compressed/piggy.lzma.S
-diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
-index ea71c0c..f5bf779 100644
--- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig
@@ -20,6 +20,7 @@ config ARM
@@ -25,11 +23,9 @@ index ea71c0c..f5bf779 100644
help
The ARM series is a line of low-power-consumption RISC chip designs
licensed by ARM Ltd and targeted at embedded applications and
-diff --git a/arch/arm/boot/compressed/Makefile b/arch/arm/boot/compressed/Makefile
-index 5b4629b..dcfcb74 100644
--- a/arch/arm/boot/compressed/Makefile
+++ b/arch/arm/boot/compressed/Makefile
-@@ -65,6 +65,7 @@ SEDFLAGS = s/TEXT_START/$(ZTEXTADDR)/;s/BSS_START/$(ZBSSADDR)/
+@@ -65,6 +65,7 @@ SEDFLAGS = s/TEXT_START/$(ZTEXTADDR)/;s/
suffix_$(CONFIG_KERNEL_GZIP) = gzip
suffix_$(CONFIG_KERNEL_LZO) = lzo
@@ -37,8 +33,6 @@ index 5b4629b..dcfcb74 100644
targets := vmlinux vmlinux.lds \
piggy.$(suffix_y) piggy.$(suffix_y).o \
-diff --git a/arch/arm/boot/compressed/misc.c b/arch/arm/boot/compressed/misc.c
-index 7e0fe4d..4e35a10 100644
--- a/arch/arm/boot/compressed/misc.c
+++ b/arch/arm/boot/compressed/misc.c
@@ -237,6 +237,10 @@ static unsigned long free_mem_end_ptr;
@@ -52,9 +46,6 @@ index 7e0fe4d..4e35a10 100644
#ifdef CONFIG_KERNEL_LZO
#include "../../../../lib/decompress_unlzo.c"
#endif
-diff --git a/arch/arm/boot/compressed/piggy.lzma.S b/arch/arm/boot/compressed/piggy.lzma.S
-new file mode 100644
-index 0000000..d7e69cf
--- /dev/null
+++ b/arch/arm/boot/compressed/piggy.lzma.S
@@ -0,0 +1,6 @@
@@ -64,6 +55,3 @@ index 0000000..d7e69cf
+ .incbin "arch/arm/boot/compressed/piggy.lzma"
+ .globl input_data_end
+input_data_end:
---
-1.6.5
-
diff --git a/target/linux/generic-2.6/patches-2.6.31/270-sched_bfs.patch b/target/linux/generic-2.6/patches-2.6.31/270-sched_bfs.patch
index c045ae3abe..9f30674ef7 100644
--- a/target/linux/generic-2.6/patches-2.6.31/270-sched_bfs.patch
+++ b/target/linux/generic-2.6/patches-2.6.31/270-sched_bfs.patch
@@ -176,7 +176,7 @@ This patch adds support for bfs v230, modified for diff size reduction
#define sched_exec() {}
--- a/init/Kconfig
+++ b/init/Kconfig
-@@ -441,9 +441,22 @@ config LOG_BUF_SHIFT
+@@ -451,9 +451,22 @@ config LOG_BUF_SHIFT
config HAVE_UNSTABLE_SCHED_CLOCK
bool
@@ -199,7 +199,7 @@ This patch adds support for bfs v230, modified for diff size reduction
default n
help
This feature lets CPU scheduler recognize task groups and control CPU
-@@ -494,6 +507,7 @@ endchoice
+@@ -504,6 +517,7 @@ endchoice
menuconfig CGROUPS
boolean "Control Group support"
diff --git a/target/linux/generic-2.6/patches-2.6.31/977-textsearch_kconfig_hacks.patch b/target/linux/generic-2.6/patches-2.6.31/977-textsearch_kconfig_hacks.patch
index 97fad7dfeb..94d6b91d8a 100644
--- a/target/linux/generic-2.6/patches-2.6.31/977-textsearch_kconfig_hacks.patch
+++ b/target/linux/generic-2.6/patches-2.6.31/977-textsearch_kconfig_hacks.patch
@@ -1,6 +1,6 @@
--- a/lib/Kconfig
+++ b/lib/Kconfig
-@@ -148,16 +148,16 @@ config REED_SOLOMON_DEC16
+@@ -152,16 +152,16 @@ config REED_SOLOMON_DEC16
# Textsearch support is select'ed if needed
#
config TEXTSEARCH
diff --git a/target/linux/generic-2.6/patches-2.6.31/998-openwrt_lzma_options.patch b/target/linux/generic-2.6/patches-2.6.31/998-openwrt_lzma_options.patch
index f9108f271b..08bb83a433 100644
--- a/target/linux/generic-2.6/patches-2.6.31/998-openwrt_lzma_options.patch
+++ b/target/linux/generic-2.6/patches-2.6.31/998-openwrt_lzma_options.patch
@@ -1,12 +1,14 @@
--- a/scripts/Makefile.lib
+++ b/scripts/Makefile.lib
-@@ -228,5 +228,5 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
+@@ -228,7 +228,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
quiet_cmd_lzma = LZMA $@
cmd_lzma = (cat $(filter-out FORCE,$^) | \
- lzma -9 && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
+ lzma e -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
(rm -f $@ ; false)
+
+ quiet_cmd_lzo = LZO $@
--- a/scripts/gen_initramfs_list.sh
+++ b/scripts/gen_initramfs_list.sh
@@ -225,7 +225,7 @@ cpio_list=