summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.30/680-phy_ar8216.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.30/680-phy_ar8216.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.30/680-phy_ar8216.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.30/680-phy_ar8216.patch b/target/linux/generic-2.6/patches-2.6.30/680-phy_ar8216.patch
index 6cb3fd4170..d9d3ce7721 100644
--- a/target/linux/generic-2.6/patches-2.6.30/680-phy_ar8216.patch
+++ b/target/linux/generic-2.6/patches-2.6.30/680-phy_ar8216.patch
@@ -1,8 +1,8 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -96,6 +96,10 @@ config ADM6996_PHY
- config MVSWITCH_PHY
- tristate "Driver for Marvell 88E6060 switches"
+@@ -100,6 +100,10 @@ config IP175C_PHY
+ tristate "Driver for IC+ IP175C/IP178C switches"
+ select SWCONFIG
+config AR8216_PHY
+ tristate "Driver for Atheros AR8216 switches"
@@ -13,9 +13,9 @@
depends on PHYLIB=y
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -16,6 +16,7 @@ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
- obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+@@ -17,6 +17,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_IP175C_PHY) += ip175c.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
+obj-$(CONFIG_AR8216_PHY) += ar8216.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o