summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.27
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.27')
-rw-r--r--target/linux/generic-2.6/patches-2.6.27/100-netfilter_layer7_2.21.patch10
-rw-r--r--target/linux/generic-2.6/patches-2.6.27/101-netfilter_layer7_pktmatch.patch10
-rw-r--r--target/linux/generic-2.6/patches-2.6.27/208-rtl8110sb_fix.patch8
-rw-r--r--target/linux/generic-2.6/patches-2.6.27/977-textsearch_kconfig_hacks.patch6
4 files changed, 17 insertions, 17 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.27/100-netfilter_layer7_2.21.patch b/target/linux/generic-2.6/patches-2.6.27/100-netfilter_layer7_2.21.patch
index 43da4e2531..e70a5fe3f3 100644
--- a/target/linux/generic-2.6/patches-2.6.27/100-netfilter_layer7_2.21.patch
+++ b/target/linux/generic-2.6/patches-2.6.27/100-netfilter_layer7_2.21.patch
@@ -16,7 +16,7 @@
+#endif /* _XT_LAYER7_H */
--- a/include/net/netfilter/nf_conntrack.h
+++ b/include/net/netfilter/nf_conntrack.h
-@@ -118,6 +118,22 @@
+@@ -118,6 +118,22 @@ struct nf_conn
u_int32_t secmark;
#endif
@@ -41,7 +41,7 @@
--- a/net/netfilter/Kconfig
+++ b/net/netfilter/Kconfig
-@@ -757,6 +757,27 @@
+@@ -757,6 +757,27 @@ config NETFILTER_XT_MATCH_STATE
To compile it as a module, choose M here. If unsure, say N.
@@ -71,7 +71,7 @@
depends on NETFILTER_XTABLES
--- a/net/netfilter/Makefile
+++ b/net/netfilter/Makefile
-@@ -78,6 +78,7 @@
+@@ -78,6 +78,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RATEEST)
obj-$(CONFIG_NETFILTER_XT_MATCH_REALM) += xt_realm.o
obj-$(CONFIG_NETFILTER_XT_MATCH_SCTP) += xt_sctp.o
obj-$(CONFIG_NETFILTER_XT_MATCH_STATE) += xt_state.o
@@ -81,7 +81,7 @@
obj-$(CONFIG_NETFILTER_XT_MATCH_TCPMSS) += xt_tcpmss.o
--- a/net/netfilter/nf_conntrack_core.c
+++ b/net/netfilter/nf_conntrack_core.c
-@@ -206,6 +206,14 @@
+@@ -206,6 +206,14 @@ destroy_conntrack(struct nf_conntrack *n
* too. */
nf_ct_remove_expectations(ct);
@@ -98,7 +98,7 @@
BUG_ON(hlist_unhashed(&ct->tuplehash[IP_CT_DIR_ORIGINAL].hnode));
--- a/net/netfilter/nf_conntrack_standalone.c
+++ b/net/netfilter/nf_conntrack_standalone.c
-@@ -162,6 +162,12 @@
+@@ -162,6 +162,12 @@ static int ct_seq_show(struct seq_file *
return -ENOSPC;
#endif
diff --git a/target/linux/generic-2.6/patches-2.6.27/101-netfilter_layer7_pktmatch.patch b/target/linux/generic-2.6/patches-2.6.27/101-netfilter_layer7_pktmatch.patch
index 4931b1bdb7..f65e301fd1 100644
--- a/target/linux/generic-2.6/patches-2.6.27/101-netfilter_layer7_pktmatch.patch
+++ b/target/linux/generic-2.6/patches-2.6.27/101-netfilter_layer7_pktmatch.patch
@@ -1,6 +1,6 @@
--- a/include/linux/netfilter/xt_layer7.h
+++ b/include/linux/netfilter/xt_layer7.h
-@@ -8,6 +8,7 @@
+@@ -8,6 +8,7 @@ struct xt_layer7_info {
char protocol[MAX_PROTOCOL_LEN];
char pattern[MAX_PATTERN_LEN];
u_int8_t invert;
@@ -10,7 +10,7 @@
#endif /* _XT_LAYER7_H */
--- a/net/netfilter/xt_layer7.c
+++ b/net/netfilter/xt_layer7.c
-@@ -314,33 +314,35 @@
+@@ -314,33 +314,35 @@ static int match_no_append(struct nf_con
}
/* add the new app data to the conntrack. Return number of bytes added. */
@@ -60,7 +60,7 @@
return length;
}
-@@ -438,7 +440,7 @@
+@@ -438,7 +440,7 @@ match(const struct sk_buff *skbin,
enum ip_conntrack_info master_ctinfo, ctinfo;
struct nf_conn *master_conntrack, *conntrack;
@@ -69,7 +69,7 @@
unsigned int pattern_result, appdatalen;
regexp * comppattern;
-@@ -466,8 +468,8 @@
+@@ -466,8 +468,8 @@ match(const struct sk_buff *skbin,
master_conntrack = master_ct(master_conntrack);
/* if we've classified it or seen too many packets */
@@ -80,7 +80,7 @@
pattern_result = match_no_append(conntrack, master_conntrack,
ctinfo, master_ctinfo, info);
-@@ -500,6 +502,25 @@
+@@ -500,6 +502,25 @@ match(const struct sk_buff *skbin,
/* the return value gets checked later, when we're ready to use it */
comppattern = compile_and_cache(info->pattern, info->protocol);
diff --git a/target/linux/generic-2.6/patches-2.6.27/208-rtl8110sb_fix.patch b/target/linux/generic-2.6/patches-2.6.27/208-rtl8110sb_fix.patch
index d3cb74fa13..4d8dfeb55f 100644
--- a/target/linux/generic-2.6/patches-2.6.27/208-rtl8110sb_fix.patch
+++ b/target/linux/generic-2.6/patches-2.6.27/208-rtl8110sb_fix.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/r8169.c
+++ b/drivers/net/r8169.c
-@@ -1507,7 +1507,7 @@ static const struct rtl_cfg_info {
+@@ -1527,7 +1527,7 @@ static const struct rtl_cfg_info {
.hw_start = rtl_hw_start_8169,
.region = 1,
.align = 0,
@@ -9,7 +9,7 @@
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
.features = RTL_FEATURE_GMII
-@@ -1516,7 +1516,7 @@ static const struct rtl_cfg_info {
+@@ -1536,7 +1536,7 @@ static const struct rtl_cfg_info {
.hw_start = rtl_hw_start_8168,
.region = 2,
.align = 8,
@@ -18,7 +18,7 @@
TxErr | TxOK | RxOK | RxErr,
.napi_event = TxErr | TxOK | RxOK | RxOverflow,
.features = RTL_FEATURE_GMII | RTL_FEATURE_MSI
-@@ -1525,7 +1525,7 @@ static const struct rtl_cfg_info {
+@@ -1545,7 +1545,7 @@ static const struct rtl_cfg_info {
.hw_start = rtl_hw_start_8101,
.region = 2,
.align = 8,
@@ -27,7 +27,7 @@
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
.features = RTL_FEATURE_MSI
-@@ -2866,10 +2866,12 @@ static irqreturn_t rtl8169_interrupt(int
+@@ -2879,10 +2879,12 @@ static irqreturn_t rtl8169_interrupt(int
goto out;
}
diff --git a/target/linux/generic-2.6/patches-2.6.27/977-textsearch_kconfig_hacks.patch b/target/linux/generic-2.6/patches-2.6.27/977-textsearch_kconfig_hacks.patch
index 9ce0484ac4..6370139efe 100644
--- a/target/linux/generic-2.6/patches-2.6.27/977-textsearch_kconfig_hacks.patch
+++ b/target/linux/generic-2.6/patches-2.6.27/977-textsearch_kconfig_hacks.patch
@@ -1,6 +1,6 @@
---- a/lib/Kconfig 2009-03-23 23:04:09.000000000 +0100
-+++ b/lib/Kconfig 2009-03-26 12:43:09.000000000 +0100
-@@ -122,13 +122,13 @@
+--- a/lib/Kconfig
++++ b/lib/Kconfig
+@@ -122,13 +122,13 @@ config TEXTSEARCH
boolean
config TEXTSEARCH_KMP