summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.27/640-mvswitch.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.27/640-mvswitch.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.27/640-mvswitch.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.27/640-mvswitch.patch b/target/linux/generic-2.6/patches-2.6.27/640-mvswitch.patch
new file mode 100644
index 0000000000..74ea255e39
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.27/640-mvswitch.patch
@@ -0,0 +1,48 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -71,6 +71,12 @@
+ ---help---
+ Currently supports the ADM6996F switch
+
++config MVSWITCH_PHY
++ tristate "Driver for Marvell switches"
++ select VLAN_8021Q
++ ---help---
++ Currently supports the Marvell 88E6060 switch.
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -13,6 +13,7 @@
+ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
++obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+--- a/drivers/net/phy/mdio_bus.c
++++ b/drivers/net/phy/mdio_bus.c
+@@ -35,6 +35,12 @@
+ #include <asm/irq.h>
+ #include <asm/uaccess.h>
+
++static void mdio_dev_release(struct device *dev)
++{
++ /* nothing to do */
++}
++
++
+ /**
+ * mdiobus_register - bring up all the PHYs on a given bus and attach them to bus
+ * @bus: target mii_bus
+@@ -85,6 +91,7 @@
+
+ phydev->dev.parent = bus->dev;
+ phydev->dev.bus = &mdio_bus_type;
++ phydev->dev.release = mdio_dev_release;
+ snprintf(phydev->dev.bus_id, BUS_ID_SIZE, PHY_ID_FMT, bus->id, i);
+
+ phydev->bus = bus;