summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.27/401-led_alix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.27/401-led_alix.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.27/401-led_alix.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.27/401-led_alix.patch b/target/linux/generic-2.6/patches-2.6.27/401-led_alix.patch
new file mode 100644
index 0000000000..1bec37ecba
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.27/401-led_alix.patch
@@ -0,0 +1,25 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -77,6 +77,12 @@
+ help
+ This option enables support for the PCEngines WRAP programmable LEDs.
+
++config LEDS_ALIX
++ tristate "LED Support for the ALIX 2/3 boards"
++ depends on LEDS_CLASS
++ help
++ This option enables support for the three LEDs on the PCEngines ALIX 2/3 boards.
++
+ config LEDS_H1940
+ tristate "LED Support for iPAQ H1940 device"
+ depends on LEDS_CLASS && ARCH_H1940
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -13,6 +13,7 @@
+ obj-$(CONFIG_LEDS_AMS_DELTA) += leds-ams-delta.o
+ obj-$(CONFIG_LEDS_NET48XX) += leds-net48xx.o
+ obj-$(CONFIG_LEDS_WRAP) += leds-wrap.o
++obj-$(CONFIG_LEDS_ALIX) += leds-alix.o
+ obj-$(CONFIG_LEDS_H1940) += leds-h1940.o
+ obj-$(CONFIG_LEDS_COBALT_QUBE) += leds-cobalt-qube.o
+ obj-$(CONFIG_LEDS_COBALT_RAQ) += leds-cobalt-raq.o