summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.25/170-netfilter_chaostables_0.8.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.25/170-netfilter_chaostables_0.8.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/170-netfilter_chaostables_0.8.patch50
1 files changed, 25 insertions, 25 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.25/170-netfilter_chaostables_0.8.patch b/target/linux/generic-2.6/patches-2.6.25/170-netfilter_chaostables_0.8.patch
index 26708c43d3..3acc1aadb0 100644
--- a/target/linux/generic-2.6/patches-2.6.25/170-netfilter_chaostables_0.8.patch
+++ b/target/linux/generic-2.6/patches-2.6.25/170-netfilter_chaostables_0.8.patch
@@ -1,17 +1,17 @@
-Index: linux-2.6.25.1/include/linux/netfilter/oot_conntrack.h
+Index: linux-2.6.25.4/include/linux/netfilter/oot_conntrack.h
===================================================================
--- /dev/null
-+++ linux-2.6.25.1/include/linux/netfilter/oot_conntrack.h
++++ linux-2.6.25.4/include/linux/netfilter/oot_conntrack.h
@@ -0,0 +1,5 @@
+#if defined(CONFIG_IP_NF_CONNTRACK) || defined(CONFIG_IP_NF_CONNTRACK_MODULE)
+# include <linux/netfilter_ipv4/ip_conntrack.h>
+#else /* linux-2.6.20+ */
+# include <net/netfilter/nf_nat_rule.h>
+#endif
-Index: linux-2.6.25.1/include/linux/netfilter/oot_trans.h
+Index: linux-2.6.25.4/include/linux/netfilter/oot_trans.h
===================================================================
--- /dev/null
-+++ linux-2.6.25.1/include/linux/netfilter/oot_trans.h
++++ linux-2.6.25.4/include/linux/netfilter/oot_trans.h
@@ -0,0 +1,14 @@
+/* Out of tree workarounds */
+#include <linux/version.h>
@@ -27,10 +27,10 @@ Index: linux-2.6.25.1/include/linux/netfilter/oot_trans.h
+# define tcp_v4_check(tcph, tcph_sz, s, d, csp) \
+ tcp_v4_check((tcph_sz), (s), (d), (csp))
+#endif
-Index: linux-2.6.25.1/include/linux/netfilter/xt_CHAOS.h
+Index: linux-2.6.25.4/include/linux/netfilter/xt_CHAOS.h
===================================================================
--- /dev/null
-+++ linux-2.6.25.1/include/linux/netfilter/xt_CHAOS.h
++++ linux-2.6.25.4/include/linux/netfilter/xt_CHAOS.h
@@ -0,0 +1,14 @@
+#ifndef _LINUX_NETFILTER_XT_CHAOS_H
+#define _LINUX_NETFILTER_XT_CHAOS_H 1
@@ -46,10 +46,10 @@ Index: linux-2.6.25.1/include/linux/netfilter/xt_CHAOS.h
+};
+
+#endif /* _LINUX_NETFILTER_XT_CHAOS_H */
-Index: linux-2.6.25.1/include/linux/netfilter/xt_portscan.h
+Index: linux-2.6.25.4/include/linux/netfilter/xt_portscan.h
===================================================================
--- /dev/null
-+++ linux-2.6.25.1/include/linux/netfilter/xt_portscan.h
++++ linux-2.6.25.4/include/linux/netfilter/xt_portscan.h
@@ -0,0 +1,8 @@
+#ifndef _LINUX_NETFILTER_XT_PORTSCAN_H
+#define _LINUX_NETFILTER_XT_PORTSCAN_H 1
@@ -59,10 +59,10 @@ Index: linux-2.6.25.1/include/linux/netfilter/xt_portscan.h
+};
+
+#endif /* _LINUX_NETFILTER_XT_PORTSCAN_H */
-Index: linux-2.6.25.1/net/netfilter/find_match.c
+Index: linux-2.6.25.4/net/netfilter/find_match.c
===================================================================
--- /dev/null
-+++ linux-2.6.25.1/net/netfilter/find_match.c
++++ linux-2.6.25.4/net/netfilter/find_match.c
@@ -0,0 +1,39 @@
+/*
+ xt_request_find_match
@@ -103,10 +103,10 @@ Index: linux-2.6.25.1/net/netfilter/find_match.c
+
+/* In case it goes into mainline, let this out-of-tree package compile */
+#define xt_request_find_match xt_request_find_match_lo
-Index: linux-2.6.25.1/net/netfilter/Kconfig
+Index: linux-2.6.25.4/net/netfilter/Kconfig
===================================================================
---- linux-2.6.25.1.orig/net/netfilter/Kconfig
-+++ linux-2.6.25.1/net/netfilter/Kconfig
+--- linux-2.6.25.4.orig/net/netfilter/Kconfig
++++ linux-2.6.25.4/net/netfilter/Kconfig
@@ -276,6 +276,14 @@ config NETFILTER_XTABLES
# alphabetically ordered list of targets
@@ -152,10 +152,10 @@ Index: linux-2.6.25.1/net/netfilter/Kconfig
config NETFILTER_XT_MATCH_MULTIPORT
tristate '"multiport" Multiple port match support'
depends on NETFILTER_XTABLES
-Index: linux-2.6.25.1/net/netfilter/Makefile
+Index: linux-2.6.25.4/net/netfilter/Makefile
===================================================================
---- linux-2.6.25.1.orig/net/netfilter/Makefile
-+++ linux-2.6.25.1/net/netfilter/Makefile
+--- linux-2.6.25.4.orig/net/netfilter/Makefile
++++ linux-2.6.25.4/net/netfilter/Makefile
@@ -50,6 +50,8 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_SECMARK
obj-$(CONFIG_NETFILTER_XT_TARGET_TCPMSS) += xt_TCPMSS.o
obj-$(CONFIG_NETFILTER_XT_TARGET_TCPOPTSTRIP) += xt_TCPOPTSTRIP.o
@@ -170,10 +170,10 @@ Index: linux-2.6.25.1/net/netfilter/Makefile
obj-$(CONFIG_NETFILTER_XT_MATCH_TIME) += xt_time.o
obj-$(CONFIG_NETFILTER_XT_MATCH_U32) += xt_u32.o
+obj-$(CONFIG_NETFILTER_XT_MATCH_PORTSCAN) += xt_portscan.o
-Index: linux-2.6.25.1/net/netfilter/xt_CHAOS.c
+Index: linux-2.6.25.4/net/netfilter/xt_CHAOS.c
===================================================================
--- /dev/null
-+++ linux-2.6.25.1/net/netfilter/xt_CHAOS.c
++++ linux-2.6.25.4/net/netfilter/xt_CHAOS.c
@@ -0,0 +1,200 @@
+/*
+ * CHAOS target for netfilter
@@ -375,10 +375,10 @@ Index: linux-2.6.25.1/net/netfilter/xt_CHAOS.c
+MODULE_DESCRIPTION("netfilter \"CHAOS\" target");
+MODULE_LICENSE("GPL");
+MODULE_ALIAS("ipt_CHAOS");
-Index: linux-2.6.25.1/net/netfilter/xt_DELUDE.c
+Index: linux-2.6.25.4/net/netfilter/xt_DELUDE.c
===================================================================
--- /dev/null
-+++ linux-2.6.25.1/net/netfilter/xt_DELUDE.c
++++ linux-2.6.25.4/net/netfilter/xt_DELUDE.c
@@ -0,0 +1,197 @@
+/*
+ * DELUDE target
@@ -577,10 +577,10 @@ Index: linux-2.6.25.1/net/netfilter/xt_DELUDE.c
+MODULE_DESCRIPTION("netfilter \"DELUDE\" target");
+MODULE_LICENSE("GPL");
+MODULE_ALIAS("ipt_DELUDE");
-Index: linux-2.6.25.1/net/netfilter/xt_portscan.c
+Index: linux-2.6.25.4/net/netfilter/xt_portscan.c
===================================================================
--- /dev/null
-+++ linux-2.6.25.1/net/netfilter/xt_portscan.c
++++ linux-2.6.25.4/net/netfilter/xt_portscan.c
@@ -0,0 +1,269 @@
+/*
+ * portscan match for netfilter
@@ -851,10 +851,10 @@ Index: linux-2.6.25.1/net/netfilter/xt_portscan.c
+MODULE_DESCRIPTION("netfilter \"portscan\" match");
+MODULE_LICENSE("GPL");
+MODULE_ALIAS("ipt_portscan");
-Index: linux-2.6.25.1/drivers/char/random.c
+Index: linux-2.6.25.4/drivers/char/random.c
===================================================================
---- linux-2.6.25.1.orig/drivers/char/random.c
-+++ linux-2.6.25.1/drivers/char/random.c
+--- linux-2.6.25.4.orig/drivers/char/random.c
++++ linux-2.6.25.4/drivers/char/random.c
@@ -1563,6 +1563,8 @@ __u32 secure_tcp_sequence_number(__be32
return seq;
}