summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.25/140-netfilter_time.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.25/140-netfilter_time.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/140-netfilter_time.patch20
1 files changed, 10 insertions, 10 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.25/140-netfilter_time.patch b/target/linux/generic-2.6/patches-2.6.25/140-netfilter_time.patch
index 9b1c4478f4..41787ccfc5 100644
--- a/target/linux/generic-2.6/patches-2.6.25/140-netfilter_time.patch
+++ b/target/linux/generic-2.6/patches-2.6.25/140-netfilter_time.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ipt_time.h
+Index: linux-2.6.25.4/include/linux/netfilter_ipv4/ipt_time.h
===================================================================
--- /dev/null
-+++ linux-2.6.25.1/include/linux/netfilter_ipv4/ipt_time.h
++++ linux-2.6.25.4/include/linux/netfilter_ipv4/ipt_time.h
@@ -0,0 +1,18 @@
+#ifndef __ipt_time_h_included__
+#define __ipt_time_h_included__
@@ -21,10 +21,10 @@ Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ipt_time.h
+
+
+#endif /* __ipt_time_h_included__ */
-Index: linux-2.6.25.1/net/ipv4/netfilter/ipt_time.c
+Index: linux-2.6.25.4/net/ipv4/netfilter/ipt_time.c
===================================================================
--- /dev/null
-+++ linux-2.6.25.1/net/ipv4/netfilter/ipt_time.c
++++ linux-2.6.25.4/net/ipv4/netfilter/ipt_time.c
@@ -0,0 +1,180 @@
+/*
+ This is a module which is used for time matching
@@ -206,10 +206,10 @@ Index: linux-2.6.25.1/net/ipv4/netfilter/ipt_time.c
+ r->tm_mon=i;
+ r->tm_mday=work-__spm[i]+1;
+}
-Index: linux-2.6.25.1/net/ipv4/netfilter/Kconfig
+Index: linux-2.6.25.4/net/ipv4/netfilter/Kconfig
===================================================================
---- linux-2.6.25.1.orig/net/ipv4/netfilter/Kconfig
-+++ linux-2.6.25.1/net/ipv4/netfilter/Kconfig
+--- linux-2.6.25.4.orig/net/ipv4/netfilter/Kconfig
++++ linux-2.6.25.4/net/ipv4/netfilter/Kconfig
@@ -63,6 +63,22 @@ config IP_NF_MATCH_IPP2P
help
Module for matching traffic of various Peer-to-Peer applications
@@ -233,10 +233,10 @@ Index: linux-2.6.25.1/net/ipv4/netfilter/Kconfig
config IP_NF_MATCH_RECENT
tristate '"recent" match support'
depends on IP_NF_IPTABLES
-Index: linux-2.6.25.1/net/ipv4/netfilter/Makefile
+Index: linux-2.6.25.4/net/ipv4/netfilter/Makefile
===================================================================
---- linux-2.6.25.1.orig/net/ipv4/netfilter/Makefile
-+++ linux-2.6.25.1/net/ipv4/netfilter/Makefile
+--- linux-2.6.25.4.orig/net/ipv4/netfilter/Makefile
++++ linux-2.6.25.4/net/ipv4/netfilter/Makefile
@@ -47,6 +47,7 @@ obj-$(CONFIG_IP_NF_MATCH_ECN) += ipt_ecn
obj-$(CONFIG_IP_NF_MATCH_RECENT) += ipt_recent.o
obj-$(CONFIG_IP_NF_MATCH_TTL) += ipt_ttl.o