summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.22/200-sched_esfq.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.22/200-sched_esfq.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.22/200-sched_esfq.patch28
1 files changed, 10 insertions, 18 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.22/200-sched_esfq.patch b/target/linux/generic-2.6/patches-2.6.22/200-sched_esfq.patch
index 67e56ee678..005f7edf3f 100644
--- a/target/linux/generic-2.6/patches-2.6.22/200-sched_esfq.patch
+++ b/target/linux/generic-2.6/patches-2.6.22/200-sched_esfq.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.22.19/include/linux/pkt_sched.h
-===================================================================
---- linux-2.6.22.19.orig/include/linux/pkt_sched.h
-+++ linux-2.6.22.19/include/linux/pkt_sched.h
-@@ -146,8 +146,40 @@ struct tc_sfq_qopt
+--- a/include/linux/pkt_sched.h
++++ b/include/linux/pkt_sched.h
+@@ -146,8 +146,40 @@
*
* The only reason for this is efficiency, it is possible
* to change these parameters in compile time.
@@ -43,11 +41,9 @@ Index: linux-2.6.22.19/include/linux/pkt_sched.h
/* RED section */
enum
-Index: linux-2.6.22.19/net/sched/Kconfig
-===================================================================
---- linux-2.6.22.19.orig/net/sched/Kconfig
-+++ linux-2.6.22.19/net/sched/Kconfig
-@@ -133,6 +133,26 @@ config NET_SCH_SFQ
+--- a/net/sched/Kconfig
++++ b/net/sched/Kconfig
+@@ -133,6 +133,26 @@
To compile this code as a module, choose M here: the
module will be called sch_sfq.
@@ -74,11 +70,9 @@ Index: linux-2.6.22.19/net/sched/Kconfig
config NET_SCH_TEQL
tristate "True Link Equalizer (TEQL)"
---help---
-Index: linux-2.6.22.19/net/sched/Makefile
-===================================================================
---- linux-2.6.22.19.orig/net/sched/Makefile
-+++ linux-2.6.22.19/net/sched/Makefile
-@@ -23,6 +23,7 @@ obj-$(CONFIG_NET_SCH_GRED) += sch_gred.o
+--- a/net/sched/Makefile
++++ b/net/sched/Makefile
+@@ -23,6 +23,7 @@
obj-$(CONFIG_NET_SCH_INGRESS) += sch_ingress.o
obj-$(CONFIG_NET_SCH_DSMARK) += sch_dsmark.o
obj-$(CONFIG_NET_SCH_SFQ) += sch_sfq.o
@@ -86,10 +80,8 @@ Index: linux-2.6.22.19/net/sched/Makefile
obj-$(CONFIG_NET_SCH_TBF) += sch_tbf.o
obj-$(CONFIG_NET_SCH_TEQL) += sch_teql.o
obj-$(CONFIG_NET_SCH_PRIO) += sch_prio.o
-Index: linux-2.6.22.19/net/sched/sch_esfq.c
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/net/sched/sch_esfq.c
++++ b/net/sched/sch_esfq.c
@@ -0,0 +1,704 @@
+/*
+ * net/sched/sch_esfq.c Extended Stochastic Fairness Queueing discipline.