summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.22/160-netfilter_route.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.22/160-netfilter_route.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.22/160-netfilter_route.patch56
1 files changed, 19 insertions, 37 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.22/160-netfilter_route.patch b/target/linux/generic-2.6/patches-2.6.22/160-netfilter_route.patch
index 3d8768e92f..109c0d3ada 100644
--- a/target/linux/generic-2.6/patches-2.6.22/160-netfilter_route.patch
+++ b/target/linux/generic-2.6/patches-2.6.22/160-netfilter_route.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ipt_ROUTE.h
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/include/linux/netfilter_ipv4/ipt_ROUTE.h
++++ b/include/linux/netfilter_ipv4/ipt_ROUTE.h
@@ -0,0 +1,23 @@
+/* Header file for iptables ipt_ROUTE target
+ *
@@ -26,10 +24,8 @@ Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ipt_ROUTE.h
+#define IPT_ROUTE_TEE 0x02
+
+#endif /*_IPT_ROUTE_H_target*/
-Index: linux-2.6.22.19/include/linux/netfilter_ipv6/ip6t_ROUTE.h
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/include/linux/netfilter_ipv6/ip6t_ROUTE.h
++++ b/include/linux/netfilter_ipv6/ip6t_ROUTE.h
@@ -0,0 +1,23 @@
+/* Header file for iptables ip6t_ROUTE target
+ *
@@ -54,10 +50,8 @@ Index: linux-2.6.22.19/include/linux/netfilter_ipv6/ip6t_ROUTE.h
+#define IP6T_ROUTE_TEE 0x02
+
+#endif /*_IP6T_ROUTE_H_target*/
-Index: linux-2.6.22.19/net/ipv4/netfilter/ipt_ROUTE.c
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/net/ipv4/netfilter/ipt_ROUTE.c
++++ b/net/ipv4/netfilter/ipt_ROUTE.c
@@ -0,0 +1,483 @@
+/*
+ * This implements the ROUTE target, which enables you to setup unusual
@@ -542,11 +536,9 @@ Index: linux-2.6.22.19/net/ipv4/netfilter/ipt_ROUTE.c
+
+module_init(init);
+module_exit(fini);
-Index: linux-2.6.22.19/net/ipv4/netfilter/Kconfig
-===================================================================
---- linux-2.6.22.19.orig/net/ipv4/netfilter/Kconfig
-+++ linux-2.6.22.19/net/ipv4/netfilter/Kconfig
-@@ -552,5 +552,22 @@ config IP_NF_TARGET_SET
+--- a/net/ipv4/netfilter/Kconfig
++++ b/net/ipv4/netfilter/Kconfig
+@@ -552,5 +552,22 @@
To compile it as a module, choose M here. If unsure, say N.
@@ -569,11 +561,9 @@ Index: linux-2.6.22.19/net/ipv4/netfilter/Kconfig
+
endmenu
-Index: linux-2.6.22.19/net/ipv4/netfilter/Makefile
-===================================================================
---- linux-2.6.22.19.orig/net/ipv4/netfilter/Makefile
-+++ linux-2.6.22.19/net/ipv4/netfilter/Makefile
-@@ -60,6 +60,7 @@ obj-$(CONFIG_IP_NF_TARGET_ECN) += ipt_EC
+--- a/net/ipv4/netfilter/Makefile
++++ b/net/ipv4/netfilter/Makefile
+@@ -60,6 +60,7 @@
obj-$(CONFIG_IP_NF_TARGET_IMQ) += ipt_IMQ.o
obj-$(CONFIG_IP_NF_TARGET_MASQUERADE) += ipt_MASQUERADE.o
obj-$(CONFIG_IP_NF_TARGET_REDIRECT) += ipt_REDIRECT.o
@@ -581,11 +571,9 @@ Index: linux-2.6.22.19/net/ipv4/netfilter/Makefile
obj-$(CONFIG_IP_NF_TARGET_NETMAP) += ipt_NETMAP.o
obj-$(CONFIG_IP_NF_TARGET_SAME) += ipt_SAME.o
obj-$(CONFIG_IP_NF_TARGET_LOG) += ipt_LOG.o
-Index: linux-2.6.22.19/net/ipv6/ndisc.c
-===================================================================
---- linux-2.6.22.19.orig/net/ipv6/ndisc.c
-+++ linux-2.6.22.19/net/ipv6/ndisc.c
-@@ -154,6 +154,8 @@ struct neigh_table nd_tbl = {
+--- a/net/ipv6/ndisc.c
++++ b/net/ipv6/ndisc.c
+@@ -154,6 +154,8 @@
.gc_thresh3 = 1024,
};
@@ -594,10 +582,8 @@ Index: linux-2.6.22.19/net/ipv6/ndisc.c
/* ND options */
struct ndisc_options {
struct nd_opt_hdr *nd_opt_array[__ND_OPT_ARRAY_MAX];
-Index: linux-2.6.22.19/net/ipv6/netfilter/ip6t_ROUTE.c
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/net/ipv6/netfilter/ip6t_ROUTE.c
++++ b/net/ipv6/netfilter/ip6t_ROUTE.c
@@ -0,0 +1,330 @@
+/*
+ * This implements the ROUTE v6 target, which enables you to setup unusual
@@ -929,11 +915,9 @@ Index: linux-2.6.22.19/net/ipv6/netfilter/ip6t_ROUTE.c
+module_init(init);
+module_exit(fini);
+MODULE_LICENSE("GPL");
-Index: linux-2.6.22.19/net/ipv6/netfilter/Kconfig
-===================================================================
---- linux-2.6.22.19.orig/net/ipv6/netfilter/Kconfig
-+++ linux-2.6.22.19/net/ipv6/netfilter/Kconfig
-@@ -209,5 +209,18 @@ config IP6_NF_RAW
+--- a/net/ipv6/netfilter/Kconfig
++++ b/net/ipv6/netfilter/Kconfig
+@@ -209,5 +209,18 @@
If you want to compile it as a module, say M here and read
<file:Documentation/kbuild/modules.txt>. If unsure, say `N'.
@@ -952,11 +936,9 @@ Index: linux-2.6.22.19/net/ipv6/netfilter/Kconfig
+
endmenu
-Index: linux-2.6.22.19/net/ipv6/netfilter/Makefile
-===================================================================
---- linux-2.6.22.19.orig/net/ipv6/netfilter/Makefile
-+++ linux-2.6.22.19/net/ipv6/netfilter/Makefile
-@@ -20,6 +20,7 @@ obj-$(CONFIG_IP6_NF_TARGET_LOG) += ip6t_
+--- a/net/ipv6/netfilter/Makefile
++++ b/net/ipv6/netfilter/Makefile
+@@ -20,6 +20,7 @@
obj-$(CONFIG_IP6_NF_RAW) += ip6table_raw.o
obj-$(CONFIG_IP6_NF_MATCH_HL) += ip6t_hl.o
obj-$(CONFIG_IP6_NF_TARGET_REJECT) += ip6t_REJECT.o