summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.21/001-squashfs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.21/001-squashfs.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.21/001-squashfs.patch46
1 files changed, 13 insertions, 33 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.21/001-squashfs.patch b/target/linux/generic-2.6/patches-2.6.21/001-squashfs.patch
index e64db466cf..eebcbd99ff 100644
--- a/target/linux/generic-2.6/patches-2.6.21/001-squashfs.patch
+++ b/target/linux/generic-2.6/patches-2.6.21/001-squashfs.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.21.7/fs/Kconfig
-===================================================================
---- linux-2.6.21.7.orig/fs/Kconfig
-+++ linux-2.6.21.7/fs/Kconfig
+--- a/fs/Kconfig
++++ b/fs/Kconfig
@@ -1371,6 +1371,71 @@ config CRAMFS
If unsure, say N.
@@ -74,10 +72,8 @@ Index: linux-2.6.21.7/fs/Kconfig
config VXFS_FS
tristate "FreeVxFS file system support (VERITAS VxFS(TM) compatible)"
depends on BLOCK
-Index: linux-2.6.21.7/fs/Makefile
-===================================================================
---- linux-2.6.21.7.orig/fs/Makefile
-+++ linux-2.6.21.7/fs/Makefile
+--- a/fs/Makefile
++++ b/fs/Makefile
@@ -68,6 +68,7 @@ obj-$(CONFIG_JBD) += jbd/
obj-$(CONFIG_JBD2) += jbd2/
obj-$(CONFIG_EXT2_FS) += ext2/
@@ -86,10 +82,8 @@ Index: linux-2.6.21.7/fs/Makefile
obj-$(CONFIG_RAMFS) += ramfs/
obj-$(CONFIG_HUGETLBFS) += hugetlbfs/
obj-$(CONFIG_CODA_FS) += coda/
-Index: linux-2.6.21.7/fs/squashfs/inode.c
-===================================================================
--- /dev/null
-+++ linux-2.6.21.7/fs/squashfs/inode.c
++++ b/fs/squashfs/inode.c
@@ -0,0 +1,2124 @@
+/*
+ * Squashfs - a compressed read only filesystem for Linux
@@ -2215,10 +2209,8 @@ Index: linux-2.6.21.7/fs/squashfs/inode.c
+MODULE_DESCRIPTION("squashfs, a compressed read-only filesystem");
+MODULE_AUTHOR("Phillip Lougher <phillip@lougher.org.uk>");
+MODULE_LICENSE("GPL");
-Index: linux-2.6.21.7/fs/squashfs/Makefile
-===================================================================
--- /dev/null
-+++ linux-2.6.21.7/fs/squashfs/Makefile
++++ b/fs/squashfs/Makefile
@@ -0,0 +1,7 @@
+#
+# Makefile for the linux squashfs routines.
@@ -2227,10 +2219,8 @@ Index: linux-2.6.21.7/fs/squashfs/Makefile
+obj-$(CONFIG_SQUASHFS) += squashfs.o
+squashfs-y += inode.o
+squashfs-y += squashfs2_0.o
-Index: linux-2.6.21.7/fs/squashfs/squashfs2_0.c
-===================================================================
--- /dev/null
-+++ linux-2.6.21.7/fs/squashfs/squashfs2_0.c
++++ b/fs/squashfs/squashfs2_0.c
@@ -0,0 +1,758 @@
+/*
+ * Squashfs - a compressed read only filesystem for Linux
@@ -2990,10 +2980,8 @@ Index: linux-2.6.21.7/fs/squashfs/squashfs2_0.c
+
+ return 1;
+}
-Index: linux-2.6.21.7/fs/squashfs/squashfs.h
-===================================================================
--- /dev/null
-+++ linux-2.6.21.7/fs/squashfs/squashfs.h
++++ b/fs/squashfs/squashfs.h
@@ -0,0 +1,86 @@
+/*
+ * Squashfs - a compressed read only filesystem for Linux
@@ -3081,10 +3069,8 @@ Index: linux-2.6.21.7/fs/squashfs/squashfs.h
+ return 0;
+}
+#endif
-Index: linux-2.6.21.7/include/linux/squashfs_fs.h
-===================================================================
--- /dev/null
-+++ linux-2.6.21.7/include/linux/squashfs_fs.h
++++ b/include/linux/squashfs_fs.h
@@ -0,0 +1,911 @@
+#ifndef SQUASHFS_FS
+#define SQUASHFS_FS
@@ -3997,10 +3983,8 @@ Index: linux-2.6.21.7/include/linux/squashfs_fs.h
+
+#endif
+#endif
-Index: linux-2.6.21.7/include/linux/squashfs_fs_i.h
-===================================================================
--- /dev/null
-+++ linux-2.6.21.7/include/linux/squashfs_fs_i.h
++++ b/include/linux/squashfs_fs_i.h
@@ -0,0 +1,45 @@
+#ifndef SQUASHFS_FS_I
+#define SQUASHFS_FS_I
@@ -4047,10 +4031,8 @@ Index: linux-2.6.21.7/include/linux/squashfs_fs_i.h
+ struct inode vfs_inode;
+};
+#endif
-Index: linux-2.6.21.7/include/linux/squashfs_fs_sb.h
-===================================================================
--- /dev/null
-+++ linux-2.6.21.7/include/linux/squashfs_fs_sb.h
++++ b/include/linux/squashfs_fs_sb.h
@@ -0,0 +1,74 @@
+#ifndef SQUASHFS_FS_SB
+#define SQUASHFS_FS_SB
@@ -4126,10 +4108,8 @@ Index: linux-2.6.21.7/include/linux/squashfs_fs_sb.h
+ int (*read_fragment_index_table)(struct super_block *s);
+};
+#endif
-Index: linux-2.6.21.7/init/do_mounts_rd.c
-===================================================================
---- linux-2.6.21.7.orig/init/do_mounts_rd.c
-+++ linux-2.6.21.7/init/do_mounts_rd.c
+--- a/init/do_mounts_rd.c
++++ b/init/do_mounts_rd.c
@@ -5,6 +5,7 @@
#include <linux/ext2_fs.h>
#include <linux/romfs_fs.h>