summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/files/drivers/ssb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic-2.6/files/drivers/ssb/Makefile')
-rw-r--r--target/linux/generic-2.6/files/drivers/ssb/Makefile23
1 files changed, 15 insertions, 8 deletions
diff --git a/target/linux/generic-2.6/files/drivers/ssb/Makefile b/target/linux/generic-2.6/files/drivers/ssb/Makefile
index 9a2b379fbf..7be3975958 100644
--- a/target/linux/generic-2.6/files/drivers/ssb/Makefile
+++ b/target/linux/generic-2.6/files/drivers/ssb/Makefile
@@ -1,11 +1,18 @@
-ssb-builtin-drivers-y += driver_chipcommon.o
-ssb-builtin-drivers-$(CONFIG_SSB_DRIVER_MIPS) += driver_mipscore.o
-ssb-builtin-drivers-$(CONFIG_SSB_DRIVER_PCICORE) += driver_pcicore.o
+# core
+ssb-y += main.o scan.o
-ssb-hostsupport-$(CONFIG_SSB_PCIHOST) += pci.o pcihost_wrapper.o
-ssb-hostsupport-$(CONFIG_SSB_PCMCIAHOST) += pcmcia.o
+# host support
+ssb-$(CONFIG_SSB_PCIHOST) += pci.o pcihost_wrapper.o
+ssb-$(CONFIG_SSB_PCMCIAHOST) += pcmcia.o
-obj-$(CONFIG_SSB) += ssb.o
+# built-in drivers
+ssb-y += driver_chipcommon.o
+ssb-$(CONFIG_SSB_DRIVER_MIPS) += driver_mipscore.o
+ssb-$(CONFIG_SSB_DRIVER_EXTIF) += driver_extif.o
+ssb-$(CONFIG_SSB_DRIVER_PCICORE) += driver_pcicore.o
-ssb-objs := main.o scan.o \
- $(ssb-hostsupport-y) $(ssb-builtin-drivers-y)
+# b43 pci-ssb-bridge driver
+# Not strictly a part of SSB, but kept here for convenience
+ssb-$(CONFIG_SSB_PCIHOST) += b43_pci_bridge.o
+
+obj-$(CONFIG_SSB) += ssb.o