summaryrefslogtreecommitdiffstats
path: root/target/linux/coldfire/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/coldfire/image/Makefile')
-rw-r--r--target/linux/coldfire/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/coldfire/image/Makefile b/target/linux/coldfire/image/Makefile
index 5eb5c2f2f1..0228a8dcf6 100644
--- a/target/linux/coldfire/image/Makefile
+++ b/target/linux/coldfire/image/Makefile
@@ -13,6 +13,11 @@ define Image/Prepare
endef
define Image/BuildKernel
+ $(TARGET_CROSS)objcopy -O binary -R .bss -R .note -R .comment \
+ -R .note.gnu.build-id -S $(LINUX_DIR)/vmlinux $(KDIR)/vmlinux.bin
+ mkimage -A m68k -O linux -T kernel -a 0x00020000 -e 0x00020000 \
+ -C none -n 'M68K OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(KDIR)/vmlinux.bin $(BIN_DIR)/openwrt-$(BOARD)-uImage
endef
define Image/Build