summaryrefslogtreecommitdiffstats
path: root/target/linux/cns3xxx/patches-3.14/200-dwc_otg_support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/cns3xxx/patches-3.14/200-dwc_otg_support.patch')
-rw-r--r--target/linux/cns3xxx/patches-3.14/200-dwc_otg_support.patch48
1 files changed, 0 insertions, 48 deletions
diff --git a/target/linux/cns3xxx/patches-3.14/200-dwc_otg_support.patch b/target/linux/cns3xxx/patches-3.14/200-dwc_otg_support.patch
deleted file mode 100644
index 6b9243e572..0000000000
--- a/target/linux/cns3xxx/patches-3.14/200-dwc_otg_support.patch
+++ /dev/null
@@ -1,48 +0,0 @@
---- a/drivers/usb/Kconfig
-+++ b/drivers/usb/Kconfig
-@@ -96,6 +96,8 @@ source "drivers/usb/host/Kconfig"
-
- source "drivers/usb/renesas_usbhs/Kconfig"
-
-+source "drivers/usb/dwc/Kconfig"
-+
- source "drivers/usb/class/Kconfig"
-
- source "drivers/usb/storage/Kconfig"
---- a/drivers/usb/core/urb.c
-+++ b/drivers/usb/core/urb.c
-@@ -17,7 +17,11 @@ static void urb_destroy(struct kref *kre
-
- if (urb->transfer_flags & URB_FREE_BUFFER)
- kfree(urb->transfer_buffer);
--
-+ if (urb->aligned_transfer_buffer) {
-+ kfree(urb->aligned_transfer_buffer);
-+ urb->aligned_transfer_buffer = 0;
-+ urb->aligned_transfer_dma = 0;
-+ }
- kfree(urb);
- }
-
---- a/include/linux/usb.h
-+++ b/include/linux/usb.h
-@@ -1431,6 +1431,9 @@ struct urb {
- unsigned int transfer_flags; /* (in) URB_SHORT_NOT_OK | ...*/
- void *transfer_buffer; /* (in) associated data buffer */
- dma_addr_t transfer_dma; /* (in) dma addr for transfer_buffer */
-+ void *aligned_transfer_buffer; /* (in) associeated data buffer */
-+ dma_addr_t aligned_transfer_dma;/* (in) dma addr for transfer_buffer */
-+ u32 aligned_transfer_buffer_length; /* (in) data buffer length */
- struct scatterlist *sg; /* (in) scatter gather buffer list */
- int num_mapped_sgs; /* (internal) mapped sg entries */
- int num_sgs; /* (in) number of entries in the sg list */
---- a/drivers/usb/Makefile
-+++ b/drivers/usb/Makefile
-@@ -8,6 +8,7 @@ obj-$(CONFIG_USB) += core/
-
- obj-$(CONFIG_USB_DWC3) += dwc3/
- obj-$(CONFIG_USB_DWC2) += dwc2/
-+obj-$(CONFIG_USB_DWC_OTG) += dwc/
-
- obj-$(CONFIG_USB_MON) += mon/
-