summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/patches-3.10/128-MIPS-BCM47XX-Add-new-file-for-device-specific-workar.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm47xx/patches-3.10/128-MIPS-BCM47XX-Add-new-file-for-device-specific-workar.patch')
-rw-r--r--target/linux/brcm47xx/patches-3.10/128-MIPS-BCM47XX-Add-new-file-for-device-specific-workar.patch72
1 files changed, 72 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/patches-3.10/128-MIPS-BCM47XX-Add-new-file-for-device-specific-workar.patch b/target/linux/brcm47xx/patches-3.10/128-MIPS-BCM47XX-Add-new-file-for-device-specific-workar.patch
new file mode 100644
index 0000000000..0e291f8175
--- /dev/null
+++ b/target/linux/brcm47xx/patches-3.10/128-MIPS-BCM47XX-Add-new-file-for-device-specific-workar.patch
@@ -0,0 +1,72 @@
+From 1f3e1c682a0b5273e3ee8799b54319971f426e6a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
+Date: Wed, 29 Jan 2014 18:06:52 +0100
+Subject: [RFC V2][PATCH] MIPS: BCM47XX: Add new file for device specific workarounds
+
+---
+V2: Drop pr_debug for devices we don't need workarounds for. It was too
+ load and not useful at all.
+---
+ arch/mips/bcm47xx/Makefile | 2 +-
+ arch/mips/bcm47xx/bcm47xx_private.h | 3 +++
+ arch/mips/bcm47xx/setup.c | 1 +
+ arch/mips/bcm47xx/workarounds.c | 25 +++++++++++++++++++++++++
+ 4 files changed, 30 insertions(+), 1 deletion(-)
+ create mode 100644 arch/mips/bcm47xx/workarounds.c
+
+--- a/arch/mips/bcm47xx/Makefile
++++ b/arch/mips/bcm47xx/Makefile
+@@ -4,4 +4,4 @@
+ #
+
+ obj-y += irq.o nvram.o prom.o serial.o setup.o time.o sprom.o
+-obj-y += board.o buttons.o leds.o
++obj-y += board.o buttons.o leds.o workarounds.o
+--- a/arch/mips/bcm47xx/bcm47xx_private.h
++++ b/arch/mips/bcm47xx/bcm47xx_private.h
+@@ -9,4 +9,7 @@ int __init bcm47xx_buttons_register(void
+ /* leds.c */
+ void __init bcm47xx_leds_register(void);
+
++/* workarounds.c */
++void __init bcm47xx_workarounds(void);
++
+ #endif
+--- a/arch/mips/bcm47xx/setup.c
++++ b/arch/mips/bcm47xx/setup.c
+@@ -248,6 +248,7 @@ static int __init bcm47xx_register_bus_c
+
+ bcm47xx_buttons_register();
+ bcm47xx_leds_register();
++ bcm47xx_workarounds();
+
+ return 0;
+ }
+--- /dev/null
++++ b/arch/mips/bcm47xx/workarounds.c
+@@ -0,0 +1,25 @@
++#include "bcm47xx_private.h"
++
++#include <linux/gpio.h>
++#include <bcm47xx_board.h>
++#include <bcm47xx.h>
++
++static void __init bcm47xx_workarounds_netgear_wnr3500l(void)
++{
++ /* Set GPIO 12 to 1 to pass power to the USB port */
++ gpio_set_value(12, 1);
++}
++
++void __init bcm47xx_workarounds(void)
++{
++ enum bcm47xx_board board = bcm47xx_board_get();
++
++ switch (board) {
++ case BCM47XX_BOARD_NETGEAR_WNR3500L:
++ bcm47xx_workarounds_netgear_wnr3500l();
++ break;
++ default:
++ /* No workaround(s) needed */
++ break;
++ }
++}