summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/patches-2.6.23/100-board_support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm47xx/patches-2.6.23/100-board_support.patch')
-rw-r--r--target/linux/brcm47xx/patches-2.6.23/100-board_support.patch81
1 files changed, 31 insertions, 50 deletions
diff --git a/target/linux/brcm47xx/patches-2.6.23/100-board_support.patch b/target/linux/brcm47xx/patches-2.6.23/100-board_support.patch
index f55c3c57fe..4ca5697487 100644
--- a/target/linux/brcm47xx/patches-2.6.23/100-board_support.patch
+++ b/target/linux/brcm47xx/patches-2.6.23/100-board_support.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.23.17/arch/mips/Kconfig
-===================================================================
---- linux-2.6.23.17.orig/arch/mips/Kconfig
-+++ linux-2.6.23.17/arch/mips/Kconfig
-@@ -4,6 +4,10 @@ config MIPS
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -4,6 +4,10 @@
# Horrible source of confusion. Die, die, die ...
select EMBEDDED
@@ -13,7 +11,7 @@ Index: linux-2.6.23.17/arch/mips/Kconfig
mainmenu "Linux/MIPS Kernel Configuration"
menu "Machine selection"
-@@ -44,6 +48,23 @@ config BASLER_EXCITE_PROTOTYPE
+@@ -44,6 +48,23 @@
note that a kernel built with this option selected will not be
able to run on normal units.
@@ -37,11 +35,9 @@ Index: linux-2.6.23.17/arch/mips/Kconfig
config MIPS_COBALT
bool "Cobalt Server"
select DMA_NONCOHERENT
-Index: linux-2.6.23.17/arch/mips/kernel/cpu-probe.c
-===================================================================
---- linux-2.6.23.17.orig/arch/mips/kernel/cpu-probe.c
-+++ linux-2.6.23.17/arch/mips/kernel/cpu-probe.c
-@@ -793,6 +793,28 @@ static inline void cpu_probe_philips(str
+--- a/arch/mips/kernel/cpu-probe.c
++++ b/arch/mips/kernel/cpu-probe.c
+@@ -793,6 +793,28 @@
}
@@ -70,7 +66,7 @@ Index: linux-2.6.23.17/arch/mips/kernel/cpu-probe.c
__init void cpu_probe(void)
{
struct cpuinfo_mips *c = &current_cpu_data;
-@@ -815,6 +837,9 @@ __init void cpu_probe(void)
+@@ -815,6 +837,9 @@
case PRID_COMP_SIBYTE:
cpu_probe_sibyte(c);
break;
@@ -80,11 +76,9 @@ Index: linux-2.6.23.17/arch/mips/kernel/cpu-probe.c
case PRID_COMP_SANDCRAFT:
cpu_probe_sandcraft(c);
break;
-Index: linux-2.6.23.17/arch/mips/kernel/proc.c
-===================================================================
---- linux-2.6.23.17.orig/arch/mips/kernel/proc.c
-+++ linux-2.6.23.17/arch/mips/kernel/proc.c
-@@ -82,6 +82,8 @@ static const char *cpu_name[] = {
+--- a/arch/mips/kernel/proc.c
++++ b/arch/mips/kernel/proc.c
+@@ -82,6 +82,8 @@
[CPU_VR4181] = "NEC VR4181",
[CPU_VR4181A] = "NEC VR4181A",
[CPU_SR71000] = "Sandcraft SR71000",
@@ -93,11 +87,9 @@ Index: linux-2.6.23.17/arch/mips/kernel/proc.c
[CPU_PR4450] = "Philips PR4450",
[CPU_LOONGSON2] = "ICT Loongson-2",
};
-Index: linux-2.6.23.17/arch/mips/Makefile
-===================================================================
---- linux-2.6.23.17.orig/arch/mips/Makefile
-+++ linux-2.6.23.17/arch/mips/Makefile
-@@ -533,6 +533,18 @@ libs-$(CONFIG_SIBYTE_BIGSUR) += arch/mip
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -533,6 +533,18 @@
load-$(CONFIG_SIBYTE_BIGSUR) := 0xffffffff80100000
#
@@ -116,11 +108,9 @@ Index: linux-2.6.23.17/arch/mips/Makefile
# SNI RM
#
core-$(CONFIG_SNI_RM) += arch/mips/sni/
-Index: linux-2.6.23.17/arch/mips/mm/tlbex.c
-===================================================================
---- linux-2.6.23.17.orig/arch/mips/mm/tlbex.c
-+++ linux-2.6.23.17/arch/mips/mm/tlbex.c
-@@ -895,6 +895,8 @@ static __init void build_tlb_write_entry
+--- a/arch/mips/mm/tlbex.c
++++ b/arch/mips/mm/tlbex.c
+@@ -895,6 +895,8 @@
case CPU_AU1550:
case CPU_AU1200:
case CPU_PR4450:
@@ -129,11 +119,9 @@ Index: linux-2.6.23.17/arch/mips/mm/tlbex.c
i_nop(p);
tlbw(p);
break;
-Index: linux-2.6.23.17/drivers/Kconfig
-===================================================================
---- linux-2.6.23.17.orig/drivers/Kconfig
-+++ linux-2.6.23.17/drivers/Kconfig
-@@ -60,6 +60,8 @@ source "drivers/power/Kconfig"
+--- a/drivers/Kconfig
++++ b/drivers/Kconfig
+@@ -60,6 +60,8 @@
source "drivers/hwmon/Kconfig"
@@ -142,10 +130,8 @@ Index: linux-2.6.23.17/drivers/Kconfig
source "drivers/mfd/Kconfig"
source "drivers/media/Kconfig"
-Index: linux-2.6.23.17/include/asm-mips/bootinfo.h
-===================================================================
---- linux-2.6.23.17.orig/include/asm-mips/bootinfo.h
-+++ linux-2.6.23.17/include/asm-mips/bootinfo.h
+--- a/include/asm-mips/bootinfo.h
++++ b/include/asm-mips/bootinfo.h
@@ -208,6 +208,12 @@
#define MACH_GROUP_WINDRIVER 28 /* Windriver boards */
#define MACH_WRPPMC 1
@@ -159,10 +145,8 @@ Index: linux-2.6.23.17/include/asm-mips/bootinfo.h
#define CL_SIZE COMMAND_LINE_SIZE
const char *get_system_type(void);
-Index: linux-2.6.23.17/include/asm-mips/cpu.h
-===================================================================
---- linux-2.6.23.17.orig/include/asm-mips/cpu.h
-+++ linux-2.6.23.17/include/asm-mips/cpu.h
+--- a/include/asm-mips/cpu.h
++++ b/include/asm-mips/cpu.h
@@ -106,6 +106,13 @@
#define PRID_IMP_SR71000 0x0400
@@ -189,19 +173,16 @@ Index: linux-2.6.23.17/include/asm-mips/cpu.h
/*
* ISA Level encodings
-Index: linux-2.6.23.17/drivers/Makefile
-===================================================================
---- linux-2.6.23.17.orig/drivers/Makefile
-+++ linux-2.6.23.17/drivers/Makefile
-@@ -90,3 +90,4 @@ obj-$(CONFIG_HID) += hid/
+--- a/drivers/Makefile
++++ b/drivers/Makefile
+@@ -89,3 +89,5 @@
+ obj-$(CONFIG_HID) += hid/
obj-$(CONFIG_PPC_PS3) += ps3/
obj-$(CONFIG_OF) += of/
- obj-$(CONFIG_GPIO_DEVICE) += gpio/
+obj-$(CONFIG_SSB) += ssb/
-Index: linux-2.6.23.17/include/linux/pci_ids.h
-===================================================================
---- linux-2.6.23.17.orig/include/linux/pci_ids.h
-+++ linux-2.6.23.17/include/linux/pci_ids.h
++
+--- a/include/linux/pci_ids.h
++++ b/include/linux/pci_ids.h
@@ -1980,6 +1980,7 @@
#define PCI_DEVICE_ID_TIGON3_5906M 0x1713
#define PCI_DEVICE_ID_BCM4401 0x4401