summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm47xx/Makefile')
-rw-r--r--target/linux/brcm47xx/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/brcm47xx/Makefile b/target/linux/brcm47xx/Makefile
index 11485fe056..5804ee9768 100644
--- a/target/linux/brcm47xx/Makefile
+++ b/target/linux/brcm47xx/Makefile
@@ -13,15 +13,15 @@ FEATURES:=squashfs usb
LINUX_VERSION:=2.6.22.4
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += kmod-switch kmod-diag
+
define Target/Description
Build firmware images for Broadcom based routers
(e.g. Netgear WGT634U)
endef
-include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += kmod-switch kmod-diag
-
# include the profiles
-include profiles/*.mk
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))