summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx-2.6/patches-2.6.22/110-flash_map.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm47xx-2.6/patches-2.6.22/110-flash_map.patch')
-rw-r--r--target/linux/brcm47xx-2.6/patches-2.6.22/110-flash_map.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/brcm47xx-2.6/patches-2.6.22/110-flash_map.patch b/target/linux/brcm47xx-2.6/patches-2.6.22/110-flash_map.patch
new file mode 100644
index 0000000000..74fe01a25f
--- /dev/null
+++ b/target/linux/brcm47xx-2.6/patches-2.6.22/110-flash_map.patch
@@ -0,0 +1,29 @@
+Index: linux-2.6.22-rc4/drivers/mtd/maps/Kconfig
+===================================================================
+--- linux-2.6.22-rc4.orig/drivers/mtd/maps/Kconfig 2007-06-10 21:32:13.000000000 +0100
++++ linux-2.6.22-rc4/drivers/mtd/maps/Kconfig 2007-06-10 21:33:14.000000000 +0100
+@@ -358,6 +358,12 @@
+ Mapping for the Flaga digital module. If you don't have one, ignore
+ this setting.
+
++config MTD_BCM47XX
++ tristate "BCM47xx flash device"
++ depends on MIPS && MTD_CFI && BCM947XX
++ help
++ Support for the flash chips on the BCM947xx board.
++
+ config MTD_WALNUT
+ tristate "Flash device mapped on IBM 405GP Walnut"
+ depends on MTD_JEDECPROBE && WALNUT
+Index: linux-2.6.22-rc4/drivers/mtd/maps/Makefile
+===================================================================
+--- linux-2.6.22-rc4.orig/drivers/mtd/maps/Makefile 2007-06-10 21:32:13.000000000 +0100
++++ linux-2.6.22-rc4/drivers/mtd/maps/Makefile 2007-06-10 21:33:14.000000000 +0100
+@@ -33,6 +33,7 @@
+ obj-$(CONFIG_MTD_PCMCIA) += pcmciamtd.o
+ obj-$(CONFIG_MTD_RPXLITE) += rpxlite.o
+ obj-$(CONFIG_MTD_TQM8XXL) += tqm8xxl.o
++obj-$(CONFIG_MTD_BCM47XX) += bcm47xx-flash.o
+ obj-$(CONFIG_MTD_SA1100) += sa1100-flash.o
+ obj-$(CONFIG_MTD_IPAQ) += ipaq-flash.o
+ obj-$(CONFIG_MTD_SBC_GXX) += sbc_gxx.o