summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm2708/image/Makefile')
-rw-r--r--target/linux/brcm2708/image/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 7a68c506cf..3744cace58 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -21,6 +21,12 @@ else
endef
endif
+define Image/Prepare
+ rm -rf $(KDIR)/overlays
+ mkdir -p $(KDIR)/overlays
+ $(CP) $(DTS_DIR)/overlays/*.dtb $(KDIR)/overlays/
+endef
+
### Image scripts ###
define Build/gen-cfg
cat config.txt > $@.config
@@ -41,6 +47,7 @@ define Build/boot-img
mcopy -i $@.boot $@.config ::config.txt
mcopy -i $@.boot $(word 1,$^) ::kernel.img
mcopy -i $@.boot $(DTS_DIR)/$(DEVICE_DTS).dtb ::$(DEVICE_DTS).dtb
+ mcopy -s -i $@.boot $(KDIR)/overlays ::
endef
define Build/sdcard-img