summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm53xx')
-rw-r--r--target/linux/bcm53xx/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 89639f4344..10474eb3b9 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -26,7 +26,7 @@ define Build/trx-serial
$(STAGING_DIR_HOST)/bin/trx \
-o $@.new \
-m 33554432 \
- -f $(word 1,$^) -a 1024 \
+ -f $(IMAGE_KERNEL) -a 1024 \
-f $@ -a 0x10000 -A $(KDIR)/fs_mark
mv $@.new $@
endef
@@ -39,7 +39,7 @@ define Build/trx-nand
$(STAGING_DIR_HOST)/bin/trx \
-o $@.new \
-m 33554432 \
- -f $(word 1,$^) -a 0x20000 -b 0x400000 \
+ -f $(IMAGE_KERNEL) -a 0x20000 -b 0x400000 \
-f $@ \
-A $(KDIR)/ubi_mark -a 0x20000
mv $@.new $@
@@ -57,7 +57,7 @@ define Build/seama-nand
entity $@.entity \
-m "dev=/dev/mtdblock/7" \
-m "type=firmware" \
- -f $(word 1,$^) \
+ -f $(IMAGE_KERNEL) \
-b 0x400000 \
-f $@ \
-f $(KDIR)/ubi_mark