summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/patches-3.18/131-ARM-BCM5301X-Implement-SMP-support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm53xx/patches-3.18/131-ARM-BCM5301X-Implement-SMP-support.patch')
-rw-r--r--target/linux/bcm53xx/patches-3.18/131-ARM-BCM5301X-Implement-SMP-support.patch23
1 files changed, 3 insertions, 20 deletions
diff --git a/target/linux/bcm53xx/patches-3.18/131-ARM-BCM5301X-Implement-SMP-support.patch b/target/linux/bcm53xx/patches-3.18/131-ARM-BCM5301X-Implement-SMP-support.patch
index 5fce97bc3f..db855c9d11 100644
--- a/target/linux/bcm53xx/patches-3.18/131-ARM-BCM5301X-Implement-SMP-support.patch
+++ b/target/linux/bcm53xx/patches-3.18/131-ARM-BCM5301X-Implement-SMP-support.patch
@@ -24,11 +24,9 @@ V2: Change code after receiving Florian's comments:
create mode 100644 arch/arm/mach-bcm/bcm5301x_headsmp.S
create mode 100644 arch/arm/mach-bcm/bcm5301x_smp.c
-diff --git a/Documentation/devicetree/bindings/arm/bcm4708.txt b/Documentation/devicetree/bindings/arm/bcm4708.txt
-index 6b0f49f..3dd0e9d 100644
--- a/Documentation/devicetree/bindings/arm/bcm4708.txt
+++ b/Documentation/devicetree/bindings/arm/bcm4708.txt
-@@ -6,3 +6,27 @@ Boards with the BCM4708 SoC shall have the following properties:
+@@ -6,3 +6,27 @@ Boards with the BCM4708 SoC shall have t
Required root node property:
compatible = "brcm,bcm4708";
@@ -56,11 +54,9 @@ index 6b0f49f..3dd0e9d 100644
+ reg = <0x0 0x1000>;
+ };
+ };
-diff --git a/Documentation/devicetree/bindings/arm/cpus.txt b/Documentation/devicetree/bindings/arm/cpus.txt
-index 6aa331d..3507ae3 100644
--- a/Documentation/devicetree/bindings/arm/cpus.txt
+++ b/Documentation/devicetree/bindings/arm/cpus.txt
-@@ -188,6 +188,7 @@ nodes to be present and contain the properties described below.
+@@ -188,6 +188,7 @@ nodes to be present and contain the prop
can be one of:
"allwinner,sun6i-a31"
"arm,psci"
@@ -68,8 +64,6 @@ index 6aa331d..3507ae3 100644
"brcm,brahma-b15"
"marvell,armada-375-smp"
"marvell,armada-380-smp"
-diff --git a/arch/arm/boot/dts/bcm4708.dtsi b/arch/arm/boot/dts/bcm4708.dtsi
-index 31141e8..c0af5cc 100644
--- a/arch/arm/boot/dts/bcm4708.dtsi
+++ b/arch/arm/boot/dts/bcm4708.dtsi
@@ -15,6 +15,7 @@
@@ -97,11 +91,9 @@ index 31141e8..c0af5cc 100644
+ };
+ };
};
-diff --git a/arch/arm/mach-bcm/Makefile b/arch/arm/mach-bcm/Makefile
-index 4c38674..ca12727 100644
--- a/arch/arm/mach-bcm/Makefile
+++ b/arch/arm/mach-bcm/Makefile
-@@ -33,6 +33,9 @@ obj-$(CONFIG_ARCH_BCM2835) += board_bcm2835.o
+@@ -33,6 +33,9 @@ obj-$(CONFIG_ARCH_BCM2835) += board_bcm2
# BCM5301X
obj-$(CONFIG_ARCH_BCM_5301X) += bcm_5301x.o
@@ -111,9 +103,6 @@ index 4c38674..ca12727 100644
# BCM63XXx
obj-$(CONFIG_ARCH_BCM_63XX) := bcm63xx.o
-diff --git a/arch/arm/mach-bcm/bcm5301x_headsmp.S b/arch/arm/mach-bcm/bcm5301x_headsmp.S
-new file mode 100644
-index 0000000..9ca8d20
--- /dev/null
+++ b/arch/arm/mach-bcm/bcm5301x_headsmp.S
@@ -0,0 +1,45 @@
@@ -162,9 +151,6 @@ index 0000000..9ca8d20
+ .align 2
+1: .long .
+ .long pen_release
-diff --git a/arch/arm/mach-bcm/bcm5301x_smp.c b/arch/arm/mach-bcm/bcm5301x_smp.c
-new file mode 100644
-index 0000000..45d7089
--- /dev/null
+++ b/arch/arm/mach-bcm/bcm5301x_smp.c
@@ -0,0 +1,158 @@
@@ -326,6 +312,3 @@ index 0000000..45d7089
+
+CPU_METHOD_OF_DECLARE(bcm5301x_smp, "brcm,bcm4708-smp",
+ &bcm5301x_smp_ops);
---
-1.8.4.5
-