summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm53xx/image/Makefile')
-rw-r--r--target/linux/bcm53xx/image/Makefile28
1 files changed, 11 insertions, 17 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 61bc39cfd6..2acf107b35 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -13,16 +13,7 @@ define Image/Prepare
$(call prepare_generic_squashfs,$(KDIR)/fs_mark)
endef
-define Image/Build/Initramfs
- $(call Image/Build/Initramfs/Chk,bcm4708-netgear-r6250,U12H245T00_NETGEAR,2,initramfs)
-endef
-
-define Image/Build/Initramfs/Chk
- $(call Image/Build/Initramfs/DTB,$(1))
- $(STAGING_DIR_HOST)/bin/mkchkimg -o $(BIN_DIR)/openwrt-$(1)-$(4).chk -k $(KDIR)/$(IMG_PREFIX)-$(4)-$(1).trx -b $(2) -r $(3)
-endef
-
-define Image/Build/Initramfs/DTB
+define Image/Build/initramfs/DTB
$(call Image/Build/DTB,zImage-initramfs,$(1))
$(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/$(IMG_PREFIX)-initramfs-$(1).trx \
-f $(KDIR)/zImage-initramfs-$(1).lzma
@@ -35,11 +26,6 @@ define Image/Build/squashfs/DTB
-a 1024 -f $(KDIR)/root.squashfs -a 0x10000 -A $(KDIR)/fs_mark
endef
-define Image/Build/squashfs/Chk
- $(call Image/Build/squashfs/DTB,$(1))
- $(STAGING_DIR_HOST)/bin/mkchkimg -o $(BIN_DIR)/openwrt-$(1)-$(4).chk -k $(KDIR)/$(IMG_PREFIX)-$(4)-$(1).trx -b $(2) -r $(3)
-endef
-
define Image/Build/DTB
rm -f $(KDIR)/$(1)-$(2).lzma
rm -f $(KDIR)/$(1)-$(2).dts
@@ -47,10 +33,18 @@ define Image/Build/DTB
$(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/$(1)-$(2).dts $(KDIR)/$(1)-$(2).lzma -d16
endef
+define Image/Build/Chk
+ $(call Image/Build/$(1)/DTB,$(2))
+ $(STAGING_DIR_HOST)/bin/mkchkimg -o $(BIN_DIR)/openwrt-$(2)-$(1).chk -k $(KDIR)/$(IMG_PREFIX)-$(1)-$(2).trx -b $(3) -r $(4)
+endef
+
+# $(1): filesystem type (e.g. squashfs, initramfs).
define Image/Build
- $(call Image/Build/$(1),$(1))
- $(call Image/Build/squashfs/Chk,bcm4708-netgear-r6250,U12H245T00_NETGEAR,2,squashfs)
+ $(call Image/Build/Chk,$(1),bcm4708-netgear-r6250,U12H245T00_NETGEAR,2)
endef
+define Image/Build/Initramfs
+ $(call Image/Build,initramfs)
+endef
$(eval $(call BuildImage))