summaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/patches-2.6.26
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/atheros/patches-2.6.26')
-rw-r--r--target/linux/atheros/patches-2.6.26/120-watchdog.patch12
-rw-r--r--target/linux/atheros/patches-2.6.26/135-ar2313_2.6.26.patch4
-rw-r--r--target/linux/atheros/patches-2.6.26/140-redboot_partition_scan.patch4
3 files changed, 8 insertions, 12 deletions
diff --git a/target/linux/atheros/patches-2.6.26/120-watchdog.patch b/target/linux/atheros/patches-2.6.26/120-watchdog.patch
index 64ac6871ce..d99b8c7813 100644
--- a/target/linux/atheros/patches-2.6.26/120-watchdog.patch
+++ b/target/linux/atheros/patches-2.6.26/120-watchdog.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.26.2/drivers/watchdog/Kconfig
-===================================================================
---- linux-2.6.26.2.orig/drivers/watchdog/Kconfig 2008-08-14 16:54:30.000000000 +0200
-+++ linux-2.6.26.2/drivers/watchdog/Kconfig 2008-08-14 16:55:40.000000000 +0200
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
@@ -683,6 +683,12 @@
help
Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
@@ -15,10 +13,8 @@ Index: linux-2.6.26.2/drivers/watchdog/Kconfig
# PARISC Architecture
# POWERPC Architecture
-Index: linux-2.6.26.2/drivers/watchdog/Makefile
-===================================================================
---- linux-2.6.26.2.orig/drivers/watchdog/Makefile 2008-08-14 16:55:44.000000000 +0200
-+++ linux-2.6.26.2/drivers/watchdog/Makefile 2008-08-14 16:58:16.000000000 +0200
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
@@ -97,6 +97,7 @@
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
diff --git a/target/linux/atheros/patches-2.6.26/135-ar2313_2.6.26.patch b/target/linux/atheros/patches-2.6.26/135-ar2313_2.6.26.patch
index e3a30d8872..97d3f1c387 100644
--- a/target/linux/atheros/patches-2.6.26/135-ar2313_2.6.26.patch
+++ b/target/linux/atheros/patches-2.6.26/135-ar2313_2.6.26.patch
@@ -1,5 +1,5 @@
---- a/drivers/net/ar2313/ar2313.c (revisione 11911)
-+++ a/drivers/net/ar2313/ar2313.c (copia locale)
+--- a/drivers/net/ar2313/ar2313.c
++++ b/drivers/net/ar2313/ar2313.c
@@ -291,7 +291,7 @@
sp->mii_bus.write = mdiobus_write;
sp->mii_bus.reset = mdiobus_reset;
diff --git a/target/linux/atheros/patches-2.6.26/140-redboot_partition_scan.patch b/target/linux/atheros/patches-2.6.26/140-redboot_partition_scan.patch
index baf8026a39..3e89407d0d 100644
--- a/target/linux/atheros/patches-2.6.26/140-redboot_partition_scan.patch
+++ b/target/linux/atheros/patches-2.6.26/140-redboot_partition_scan.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/redboot.c
+++ b/drivers/mtd/redboot.c
-@@ -59,31 +59,32 @@
+@@ -62,31 +62,32 @@
static char nullstring[] = "unallocated";
#endif
@@ -40,7 +40,7 @@
printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
master->name, offset);
-@@ -155,6 +156,11 @@
+@@ -158,6 +159,11 @@
}
if (i == numslots) {
/* Didn't find it */